Static Code Injection in microweber/microweber
Priority MEDIUM 46CWE-96Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
Static Code Injection in GitHub repository microweber/microweber prior to 1.3.
Why it matters now
EPSS 0.01748 77th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed microweber/microweber (microweber): 1.3microweber/microweber (Packagist): 1.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| microweber | microweber/microweber | before 1.3 | 1.3 | Patch available | CNA |
| — | microweber/microweber (Packagist) | before 1.3 | 1.3 | Patch available | GHSA-x28w-hvwc-mp75 |
- microweber/microweber Vendormicroweber Affected before 1.3 Fixed in 1.3 Patch available CNA
- microweber/microweber (Packagist) Vendor— Affected before 1.3 Fixed in 1.3 Patch available GHSA-x28w-hvwc-mp75
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:microweber:microweber:*:*:*:*:*:*:*:* | before 1.3 | Vulnerable | microweber |
- cpe:2.3:a:microweber:microweber:*:*:*:*:*:*:*:* Versions before 1.3 Vulnerable ·microweber
Remediation
- Fix · CNA microweber/microweber (microweber) Fixed in 1.3
- Fix · GHSA-x28w-hvwc-mp75 microweber/microweber (Packagist) Fixed in 1.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-0895
- 2026-10-03 Alias added: GHSA-x28w-hvwc-mp75
References
More Microweber vulnerabilities
- TI-2023-01763 Command Injection in microweber/microweber CVSS 3.1CRITICAL 9.8
- TI-2023-02100 Improper Privilege Management in microweber/microweber CVSS 3.1HIGH 8.8
- TI-2022-14518 Microweber v1.2.15 was discovered to allow attackers to perform an account takeover via a host header injection attack. CVSS 3.1HIGH 8.8
- TI-2023-04891 Use of Hard-coded Credentials in microweber/microweber CVSS 3.1HIGH 7.5
- TI-2025-37870 Microweber CMS 2.0 has Weak Password Requirements. CVSS 3.1HIGH 8.3
- TI-2022-04247 Cross-site Scripting (XSS) - Stored in microweber/microweber CVSS 3.1MEDIUM 6.1
Sources
- CVE-2022-0895 · CVE Program
- CVE-2022-0895 · NVD
- FIRST EPSS
- GHSA-x28w-hvwc-mp75 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences