SQL injection in moodle
Priority MEDIUM 40CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
An SQL injection risk was identified in Badges code relating to configuring criteria. Access to the relevant capability was limited to teachers and managers by default.
Why it matters now
EPSS 0.00909 60th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.11.6, 3.10.10, 3.9.13
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | moodle | moodle 3.11.6, moodle 3.10.10, moodle 3.9.13 | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 3.11.0 to before 3.11.6 | 3.11.6 | Patch available | GHSA-h2fw-93qx-vrcq |
| — | moodle/moodle (Packagist) | 3.10.0 to before 3.10.10 | 3.10.10 | Patch available | GHSA-h2fw-93qx-vrcq |
| — | moodle/moodle (Packagist) | before 3.9.13 | 3.9.13 | Patch available | GHSA-h2fw-93qx-vrcq |
- moodle Vendor— Affected moodle 3.11.6, moodle 3.10.10, moodle 3.9.13 Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 3.11.0 to before 3.11.6 Fixed in 3.11.6 Patch available GHSA-h2fw-93qx-vrcq
- moodle/moodle (Packagist) Vendor— Affected 3.10.0 to before 3.10.10 Fixed in 3.10.10 Patch available GHSA-h2fw-93qx-vrcq
- moodle/moodle (Packagist) Vendor— Affected before 3.9.13 Fixed in 3.9.13 Patch available GHSA-h2fw-93qx-vrcq
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | 3.9.0 to before 3.9.13; 3.10.0 to before 3.10.10; 3.11.0 to before 3.11.6 | Vulnerable | Moodle |
| cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* | 35 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:* | 36 | Vulnerable | Fedoraproject |
| cpe:2.3:a:fedoraproject:extra_packages_for_enterprise_linux:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Fedoraproject |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 3.9.0 to before 3.9.13; 3.10.0 to before 3.10.10; 3.11.0 to before 3.11.6 Vulnerable ·Moodle
- cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* Versions 35 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:* Versions 36 Vulnerable ·Fedoraproject
- cpe:2.3:a:fedoraproject:extra_packages_for_enterprise_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Fedoraproject
Remediation
- Fix · GHSA-h2fw-93qx-vrcq moodle/moodle (Packagist) Fixed in 3.11.6 Advisory →
- Fix · GHSA-h2fw-93qx-vrcq moodle/moodle (Packagist) Fixed in 3.10.10 Advisory →
- Fix · GHSA-h2fw-93qx-vrcq moodle/moodle (Packagist) Fixed in 3.9.13 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2022-0983
- 2026-10-03 Alias added: GHSA-h2fw-93qx-vrcq
References
Advisory 3
Sources
- CVE-2022-0983 · CVE Program
- CVE-2022-0983 · NVD
- FIRST EPSS
- GHSA-h2fw-93qx-vrcq · GitHub Advisory Database · CC BY 4.0
- CVE-2022-0983 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences