Incorrect authorization in moodle
Priority LOW 21CWE-863Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
Users with the capability to configure badge criteria (teachers and managers by default) were able to configure course badges with profile field criteria, which should only be available for site badges.
Why it matters now
EPSS 0.00557 46th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.11.6, 3.10.10, 3.9.13
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | moodle | moodle 3.11.6, moodle 3.10.10, moodle 3.9.13 | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 3.11.0 to before 3.11.6 | 3.11.6 | Patch available | GHSA-c5hf-mc85-2hx4 |
| — | moodle/moodle (Packagist) | 3.10.0 to before 3.10.10 | 3.10.10 | Patch available | GHSA-c5hf-mc85-2hx4 |
| — | moodle/moodle (Packagist) | before 3.9.13 | 3.9.13 | Patch available | GHSA-c5hf-mc85-2hx4 |
- moodle Vendor— Affected moodle 3.11.6, moodle 3.10.10, moodle 3.9.13 Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 3.11.0 to before 3.11.6 Fixed in 3.11.6 Patch available GHSA-c5hf-mc85-2hx4
- moodle/moodle (Packagist) Vendor— Affected 3.10.0 to before 3.10.10 Fixed in 3.10.10 Patch available GHSA-c5hf-mc85-2hx4
- moodle/moodle (Packagist) Vendor— Affected before 3.9.13 Fixed in 3.9.13 Patch available GHSA-c5hf-mc85-2hx4
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | 3.9.0 to before 3.9.13; 3.10.0 to before 3.10.10; 3.11.0 to before 3.11.6 | Vulnerable | Moodle |
| cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:* | 34 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* | 35 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:* | 36 | Vulnerable | Fedoraproject |
| cpe:2.3:o:redhat:enterprise_linux:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Red Hat |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 3.9.0 to before 3.9.13; 3.10.0 to before 3.10.10; 3.11.0 to before 3.11.6 Vulnerable ·Moodle
- cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:* Versions 34 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* Versions 35 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:* Versions 36 Vulnerable ·Fedoraproject
- cpe:2.3:o:redhat:enterprise_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Red Hat
Remediation
- Fix · GHSA-c5hf-mc85-2hx4 moodle/moodle (Packagist) Fixed in 3.11.6 Advisory →
- Fix · GHSA-c5hf-mc85-2hx4 moodle/moodle (Packagist) Fixed in 3.10.10 Advisory →
- Fix · GHSA-c5hf-mc85-2hx4 moodle/moodle (Packagist) Fixed in 3.9.13 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2022-0984
- 2026-10-03 Alias added: GHSA-c5hf-mc85-2hx4
References
Sources
- CVE-2022-0984 · CVE Program
- CVE-2022-0984 · NVD
- FIRST EPSS
- GHSA-c5hf-mc85-2hx4 · GitHub Advisory Database · CC BY 4.0
- CVE-2022-0984 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences