Read the docs
TI-2022-00893 Aliases CVE-2022-0994GHSA-fw4c-rcwv-gpjf

Hummingbird < 3.3.2 - Admin+ Stored Cross-Site Scripting

Priority LOW 27CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The Hummingbird WordPress plugin before 3.3.2 does not sanitise and escape the Config Name, which could allow high privilege users, such as admin to perform cross-Site Scripting attacks even when the unfiltered_html capability is disallowed

Why it matters now

EPSS 0.02793 86th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Hummingbird – Optimize Speed, Enable Cache, Minify CSS & Defer Critical JS (Unknown): 3.3.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownHummingbird – Optimize Speed, Enable Cache, Minify CSS & Defer Critical JS3.3.2 to before 3.3.23.3.2Patch availableCNA
  • Hummingbird – Optimize Speed, Enable Cache, Minify CSS & Defer Critical JS VendorUnknown Affected 3.3.2 to before 3.3.2 Fixed in 3.3.2 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:incsub:hummingbird:*:*:*:*:*:wordpress:*:*before 3.3.2VulnerableIncsub
  • cpe:2.3:a:incsub:hummingbird:*:*:*:*:*:wordpress:*:* Versions before 3.3.2 Vulnerable ·Incsub

Remediation

  • Fix · CNA Hummingbird – Optimize Speed, Enable Cache, Minify CSS & Defer Critical JS (Unknown) Fixed in 3.3.2

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-0994
  2. 2026-10-03 Alias added: GHSA-fw4c-rcwv-gpjf

References

  • TI-2023-01397 Hummingbird < 3.4.2 - Unauthenticated Path Traversal CVSS 3.1CRITICAL 9.8
  • TI-2024-28789 WordPress Hummingbird plugin <= 3.9.1 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
  • TI-2024-21666 WordPress Hummingbird plugin <= 3.7.3 - Broken Access Control vulnerability CVSS 3.1MEDIUM 5.3

Sources