Read the docs
TI-2022-00900 Aliases CVE-2022-1001GHSA-x9cg-qwvm-rg5j

WP Downgrade < 1.2.3 - Admin+ Stored Cross-Site Scripting

Priority LOW 30CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The WP Downgrade WordPress plugin before 1.2.3 only perform client side validation of its "WordPress Target Version" settings, but does not sanitise and escape it server side, allowing high privilege users such as admin to perform Cross-Site attacks even when the unfiltered_html capability is disallowed

Why it matters now

EPSS 0.04856 92nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed WP Downgrade | Specific Core Version (Unknown): 1.2.3

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownWP Downgrade | Specific Core Version1.2.3 to before 1.2.31.2.3Patch availableCNA
  • WP Downgrade | Specific Core Version VendorUnknown Affected 1.2.3 to before 1.2.3 Fixed in 1.2.3 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:wp_downgrade_project:wp_downgrade:*:*:*:*:*:wordpress:*:*before 1.2.3VulnerableWp Downgrade Project
  • cpe:2.3:a:wp_downgrade_project:wp_downgrade:*:*:*:*:*:wordpress:*:* Versions before 1.2.3 Vulnerable ·Wp Downgrade Project

Remediation

  • Fix · CNA WP Downgrade | Specific Core Version (Unknown) Fixed in 1.2.3

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-1001
  2. 2026-10-03 Alias added: GHSA-x9cg-qwvm-rg5j

References

Sources