WordPress Security < 4.2.1 - Admin+ Stored Cross-Site Scripting
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The WordPress Security Firewall, Malware Scanner, Secure Login and Backup plugin before 4.2.1 does not sanitise and escape some of its settings, leading to malicious users with administrator privileges to store malicious Javascript code leading to Cross-Site Scripting attacks when unfiltered_html is disallowed (for example in multisite setup)
Why it matters now
EPSS 0.00585 48th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed WordPress Security – Firewall, Malware Scanner, Secure Login and Backup (Unknown): 4.2.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WordPress Security – Firewall, Malware Scanner, Secure Login and Backup | 4.2.1 to before 4.2.1 | 4.2.1 | Patch available | CNA |
- WordPress Security – Firewall, Malware Scanner, Secure Login and Backup VendorUnknown Affected 4.2.1 to before 4.2.1 Fixed in 4.2.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:miniorange:wordpress_security:*:*:*:*:*:wordpress:*:* | before 4.2.1 | Vulnerable | miniOrange |
- cpe:2.3:a:miniorange:wordpress_security:*:*:*:*:*:wordpress:*:* Versions before 4.2.1 Vulnerable ·miniOrange
Remediation
- Fix · CNA WordPress Security – Firewall, Malware Scanner, Secure Login and Backup (Unknown) Fixed in 4.2.1
Timeline
- 2026-10-02 Threatist record created from CVE-2022-1028
- 2026-10-03 Alias added: GHSA-p7f4-wpx9-f83x
References
Sources
- CVE-2022-1028 · CVE Program
- CVE-2022-1028 · NVD
- FIRST EPSS
- GHSA-p7f4-wpx9-f83x · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences