Read the docs
TI-2022-00933 Aliases CVE-2022-1036GHSA-3qr6-qrqm-8v86

Able to create an account with long password leads to memory corruption / Integer Overflow in microweber/microweber

Priority LOW 35CWE-190Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-190 and the CVSS impact.

Summary

Able to create an account with long password leads to memory corruption / Integer Overflow in GitHub repository microweber/microweber prior to 1.2.12.

Why it matters now

EPSS 0.01226 69th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed microweber/microweber (microweber): 1.2.12microweber/microweber (Packagist): 1.2.12

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
microwebermicroweber/microweberbefore 1.2.121.2.12Patch availableCNA
—microweber/microweber (Packagist)before 1.2.121.2.12Patch availableGHSA-3qr6-qrqm-8v86
  • microweber/microweber Vendormicroweber Affected before 1.2.12 Fixed in 1.2.12 Patch available CNA
  • microweber/microweber (Packagist) Vendor— Affected before 1.2.12 Fixed in 1.2.12 Patch available GHSA-3qr6-qrqm-8v86

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:microweber:microweber:*:*:*:*:*:*:*:*before 1.2.12Vulnerablemicroweber
  • cpe:2.3:a:microweber:microweber:*:*:*:*:*:*:*:* Versions before 1.2.12 Vulnerable ·microweber

Remediation

  • Fix · CNA microweber/microweber (microweber) Fixed in 1.2.12
  • Fix · GHSA-3qr6-qrqm-8v86 microweber/microweber (Packagist) Fixed in 1.2.12 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-1036
  2. 2026-10-03 Alias added: GHSA-3qr6-qrqm-8v86

References

  • TI-2023-01763 Command Injection in microweber/microweber CVSS 3.1CRITICAL 9.8
  • TI-2023-02100 Improper Privilege Management in microweber/microweber CVSS 3.1HIGH 8.8
  • TI-2022-14518 Microweber v1.2.15 was discovered to allow attackers to perform an account takeover via a host header injection attack. CVSS 3.1HIGH 8.8
  • TI-2023-04891 Use of Hard-coded Credentials in microweber/microweber CVSS 3.1HIGH 7.5
  • TI-2025-37870 Microweber CMS 2.0 has Weak Password Requirements. CVSS 3.1HIGH 8.3
  • TI-2022-04247 Cross-site Scripting (XSS) - Stored in microweber/microweber CVSS 3.1MEDIUM 6.1
See all 113 →

Sources