Read the docs
TI-2022-01018 Aliases CVE-2022-1123GHSA-q7xc-mr7x-v3ph

Leaflet Maps Marker < 3.12.5 - Admin+ SQLi

Priority LOW 34CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Impact type
SQL injection
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-89.

Summary

The Leaflet Maps Marker (Google Maps, OpenStreetMap, Bing Maps) WordPress plugin before 3.12.5 does not properly sanitize some parameters before inserting them into SQL queries. As a result, high privilege users could perform SQL injection attacks.

Why it matters now

EPSS 0.01357 71st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Leaflet Maps Marker (Google Maps, OpenStreetMap, Bing Maps) (Unknown): 3.12.5

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownLeaflet Maps Marker (Google Maps, OpenStreetMap, Bing Maps)3.12.5 to before 3.12.53.12.5Patch availableCNA
  • Leaflet Maps Marker (Google Maps, OpenStreetMap, Bing Maps) VendorUnknown Affected 3.12.5 to before 3.12.5 Fixed in 3.12.5 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:mapsmarker:leaflet_maps_marker:*:*:*:*:*:wordpress:*:*before 3.12.5VulnerableMapsmarker
  • cpe:2.3:a:mapsmarker:leaflet_maps_marker:*:*:*:*:*:wordpress:*:* Versions before 3.12.5 Vulnerable ·Mapsmarker

Remediation

  • Fix · CNA Leaflet Maps Marker (Google Maps, OpenStreetMap, Bing Maps) (Unknown) Fixed in 3.12.5

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-1123
  2. 2026-10-03 Alias added: GHSA-q7xc-mr7x-v3ph

References

  • TI-2022-04275 Leaflet Maps Marker (Google Maps, OpenStreetMap, Bing Maps) < 3.12.7 - Contributor+ Stored XSS via Shortcode CVSS 3.1MEDIUM 5.4
  • TI-2024-26015 WordPress Leaflet Maps Marker plugin <= 3.12.9 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5

Sources