Leaflet Maps Marker (Google Maps, OpenStreetMap, Bing Maps) < 3.12.7 - Contributor+ Stored XSS via Shortcode
Priority MEDIUM 58Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Leaflet Maps Marker WordPress plugin before 3.12.7 does not validate and escape one of its shortcode attributes, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attack.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00562 46th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Leaflet Maps Marker (Google Maps, OpenStreetMap, Bing Maps) (Unknown): 3.12.7
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Leaflet Maps Marker (Google Maps, OpenStreetMap, Bing Maps) | before 3.12.7 | 3.12.7 | Patch available | CNA |
- Leaflet Maps Marker (Google Maps, OpenStreetMap, Bing Maps) VendorUnknown Affected before 3.12.7 Fixed in 3.12.7 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mapsmarker:leaflet_maps_marker:*:*:*:*:*:wordpress:*:* | before 3.12.7 | Vulnerable | Mapsmarker |
- cpe:2.3:a:mapsmarker:leaflet_maps_marker:*:*:*:*:*:wordpress:*:* Versions before 3.12.7 Vulnerable ·Mapsmarker
Remediation
- Fix · CNA Leaflet Maps Marker (Google Maps, OpenStreetMap, Bing Maps) (Unknown) Fixed in 3.12.7
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4677
- 2026-10-03 Alias added: GHSA-xj8j-j953-4q85
References
More Mapsmarker Leaflet Maps Marker vulnerabilities
- TI-2022-01018 Leaflet Maps Marker < 3.12.5 - Admin+ SQLi CVSS 3.1HIGH 7.2
- TI-2024-26015 WordPress Leaflet Maps Marker plugin <= 3.12.9 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
Sources
- CVE-2022-4677 · CVE Program
- CVE-2022-4677 · NVD
- FIRST EPSS
- GHSA-xj8j-j953-4q85 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences