Ultimate Member <= 2.3.2 - Stored Cross-Site Scripting
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The Ultimate Member plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Biography field featured on individual user profile pages due to insufficient input sanitization and output escaping that allows users to encode malicious web scripts with HTML encoding that is reflected back on the page. This affects versions up to, and including, 2.3.2. Please note this issue was only partially fixed in version 2.3.2.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ultimatemember | Ultimate Member – User Profile, Registration, Login, Member Directory, Content Restriction & Membership Plugin | up to 2.3.2 | — | No fix listed | CNA |
- Ultimate Member – User Profile, Registration, Login, Member Directory, Content Restriction & Membership Plugin Vendorultimatemember Affected up to 2.3.2 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ultimatemember:ultimate_member:*:*:*:*:*:wordpress:*:* | up to 2.3.2 | Vulnerable | ultimatemember |
- cpe:2.3:a:ultimatemember:ultimate_member:*:*:*:*:*:wordpress:*:* Versions up to 2.3.2 Vulnerable ·ultimatemember
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2022-1208
- 2026-10-03 Alias added: GHSA-v6w4-v9mr-x4m3
References
More ultimatemember Ultimate Member vulnerabilities
- TI-2024-00992 SQL injection in ultimatemember Ultimate Member – User Profile, Registration, Login… CVSS 3.1CRITICAL 9.8
- TI-2023-03232 Ultimate Member < 2.6.7 - Unauthenticated Privilege Escalation CVSS 3.1CRITICAL 9.8
- TI-2024-01973 Ultimate Member <= 2.8.3 - Unauthenticated Stored Cross-Site Scripting CVSS 3.1HIGH 7.2
- TI-2020-18475 An issue was discovered in the Ultimate Member plugin before 2.1.12 for WordPress, aka… CVSS 3.1CRITICAL 10.0
- TI-2020-18477 An issue was discovered in the Ultimate Member plugin before 2.1.12 for WordPress, aka… CVSS 3.1CRITICAL 10.0
- TI-2020-18476 An issue was discovered in the Ultimate Member plugin before 2.1.12 for WordPress, aka… CVSS 3.1CRITICAL 9.9
Sources
- CVE-2022-1208 · CVE Program
- CVE-2022-1208 · NVD
- FIRST EPSS
- GHSA-v6w4-v9mr-x4m3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences