Authorized users are allowed to install old plugin versions from the Marketplace
Priority LOW 39CWE-477Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-862.
Summary
Mattermost version 6.4.x and earlier fails to properly check the plugin version when a plugin is installed from the Marketplace, which allows an authenticated and an authorized user to install and exploit an old plugin version from the Marketplace which might have known vulnerabilities.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00675 52nd percentileScored 2026-11-07
Fix Fixed github.com/mattermost/mattermost-server/v6 (Go): 6.5.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Mattermost | Mattermost | up to 6.4 | — | No fix listed | CNA |
| — | github.com/mattermost/mattermost-server/v6 (Go) | 6.4.0 to before 6.5.0 | 6.5.0 | Patch available | GHSA-32rp-q37p-jg6w |
- Mattermost VendorMattermost Affected up to 6.4 Fixed in — No fix listed CNA
- github.com/mattermost/mattermost-server/v6 (Go) Vendor— Affected 6.4.0 to before 6.5.0 Fixed in 6.5.0 Patch available GHSA-32rp-q37p-jg6w
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* | before 6.5.0 | Vulnerable | Mattermost |
- cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* Versions before 6.5.0 Vulnerable ·Mattermost
Remediation
- Fix · GHSA-32rp-q37p-jg6w github.com/mattermost/mattermost-server/v6 (Go) Fixed in 6.5.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-1384
- 2026-10-03 Alias added: GHSA-32rp-q37p-jg6w
References
More Mattermost Server vulnerabilities
- TI-2025-18933 Arbitrary file read in Mattermost Boards via import & export board archive CVSS 3.1CRITICAL 9.9
- TI-2025-04465 Path Traversal Leading to RCE by Any Authenticated Mattermost User CVSS 3.1CRITICAL 9.9
- TI-2017-14068 An issue was discovered in Mattermost Server before 3.6.2. CVSS 3.1CRITICAL 9.8
- TI-2017-14060 An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7. CVSS 3.1CRITICAL 9.8
- TI-2017-14048 An issue was discovered in Mattermost Server before 4.1.0, 4.0.4, and 3.10.3. CVSS 3.1CRITICAL 9.8
- TI-2025-14360 Arbitrary file read via block duplication in Mattermost Boards CVSS 3.1CRITICAL 9.9
Sources
- CVE-2022-1384 · CVE Program
- CVE-2022-1384 · NVD
- FIRST EPSS
- GHSA-32rp-q37p-jg6w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences