WPC Smart Wishlist for WooCommerce < 2.9.9 - Reflected Cross-Site Scripting
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The WPC Smart Wishlist for WooCommerce WordPress plugin before 2.9.9 does not sanitise and escape a parameter before outputting it back in an attribute via an AJAX action, leading to a Reflected Cross-Site Scripting issue.
Why it matters now
EPSS 0.00862 58th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed WPC Smart Wishlist for WooCommerce (Unknown): 2.9.9
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WPC Smart Wishlist for WooCommerce | 2.9.9 to before 2.9.9 | 2.9.9 | Patch available | CNA |
- WPC Smart Wishlist for WooCommerce VendorUnknown Affected 2.9.9 to before 2.9.9 Fixed in 2.9.9 Patch available CNA
Remediation
- Fix · CNA WPC Smart Wishlist for WooCommerce (Unknown) Fixed in 2.9.9
Timeline
- 2026-10-02 Threatist record created from CVE-2022-1465
- 2026-10-03 Alias added: GHSA-576g-v6q3-g4rh
References
More wpclever Wpc Smart Wishlist For Woocommerce vulnerabilities
- TI-2023-17216 WordPress WPC Smart Wishlist for WooCommerce Plugin <= 4.7.1 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2022-00322 WPC Smart Wishlist for WooCommerce < 2.9.4 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 5.4
Sources
- CVE-2022-1465 · CVE Program
- CVE-2022-1465 · NVD
- FIRST EPSS
- GHSA-576g-v6q3-g4rh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences