WordPress Ping Optimizer < 2.35.1.3.0 - Arbitrary Settings Update via CSRF
Priority LOW 20CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-352.
Summary
The WordPress Ping Optimizer WordPress plugin before 2.35.1.3.0 does not have CSRF check in place when updating its settings, which could allow attackers to make a logged in admin change them via a CSRF attack
Why it matters now
EPSS 0.00342 27th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed WordPress Ping Optimizer (Unknown): 2.35.1.3.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WordPress Ping Optimizer | 2.35.1.3.0 to before 2.35.1.3.0 | 2.35.1.3.0 | Patch available | CNA |
- WordPress Ping Optimizer VendorUnknown Affected 2.35.1.3.0 to before 2.35.1.3.0 Fixed in 2.35.1.3.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wordpress_ping_optimizer_project:wordpress_ping_optimizer:*:*:*:*:*:wordpress:*:* | before 2.35.1.3.0 | Vulnerable | Wordpress Ping Optimizer Project |
- cpe:2.3:a:wordpress_ping_optimizer_project:wordpress_ping_optimizer:*:*:*:*:*:wordpress:*:* Versions before 2.35.1.3.0 Vulnerable ·Wordpress Ping Optimizer Project
Remediation
- Fix · CNA WordPress Ping Optimizer (Unknown) Fixed in 2.35.1.3.0
Timeline
- 2026-10-02 Threatist record created from CVE-2022-1591
- 2026-10-03 Alias added: GHSA-q32v-53r7-3hqv
References
More Wordpress Ping Optimizer Project Wordpress Ping Optimizer vulnerabilities
- TI-2023-05861 WordPress Ping Optimizer <= 2.35.1.3.0 - Log Clearing via CSRF CVSS 3.1MEDIUM 4.3
- TI-2022-12841 WordPress WordPress Ping Optimizer Plugin <= 2.35.1.2.3 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
Sources
- CVE-2022-1591 · CVE Program
- CVE-2022-1591 · NVD
- FIRST EPSS
- GHSA-q32v-53r7-3hqv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences