WP-Invoice <= 4.3.1 - Stored Cross-Site Scripting via CSRF
Priority MEDIUM 60CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-352.
Summary
The WP-Invoice WordPress plugin through 4.3.1 does not have CSRF check in place when updating its settings, and is lacking sanitisation as well as escaping in some of them, allowing attacker to make a logged in admin change them and add XSS payload in them
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00266 18th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix No fix listed No fixed version in the sources yet
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WP-Invoice | up to 4.3.1 | — | No fix listed | CNA |
- WP-Invoice VendorUnknown Affected up to 4.3.1 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:usabilitydynamics:wp-invoice:*:*:*:*:*:wordpress:*:* | up to 4.3.1 | Vulnerable | usability_dynamics |
- cpe:2.3:a:usabilitydynamics:wp-invoice:*:*:*:*:*:wordpress:*:* Versions up to 4.3.1 Vulnerable ·usability_dynamics
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2022-1617
- 2026-10-03 Alias added: GHSA-qp39-g94h-cxxf
References
More usability_dynamics Wp-invoice vulnerabilities
- TI-2016-09049 The wp-invoice plugin before 4.1.1 for WordPress has wpi_update_user_option privilege escalation. CVSS 3.1MEDIUM 6.5
- TI-2016-09048 The wp-invoice plugin before 4.1.1 for WordPress has incorrect access control over… CVSS 3.1MEDIUM 5.3
- TI-2016-09047 The wp-invoice plugin before 4.1.1 for WordPress has incorrect access control over… CVSS 3.1MEDIUM 5.3
- TI-2016-09046 The wp-invoice plugin before 4.1.1 for WordPress has incorrect access control over wpi_paypal payer metadata updates. CVSS 3.1MEDIUM 5.3
- TI-2016-09045 The wp-invoice plugin before 4.1.1 for WordPress has incorrect access control over wpi_user_id for invoice retrieval. CVSS 3.1MEDIUM 5.3
- TI-2016-09044 The wp-invoice plugin before 4.1.1 for WordPress has incorrect access control for admin_init settings changes. CVSS 3.1MEDIUM 5.3
Sources
- CVE-2022-1617 · CVE Program
- CVE-2022-1617 · NVD
- FIRST EPSS
- GHSA-qp39-g94h-cxxf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences