Read the docs
TI-2022-01495 Aliases CVE-2022-1625GHSA-573v-fpj9-9qh6

New User Approve < 2.4 - Arbitrary Settings Update & Invitation Code Creation via CSRF

Priority LOW 20CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
None · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-352.

Summary

The New User Approve WordPress plugin before 2.4 does not have CSRF check in place when updating its settings and adding invitation codes, which could allow attackers to add invitation codes (for bypassing the provided restrictions) and to change plugin settings by tricking admin users into visiting specially crafted websites.

Why it matters now

EPSS 0.00382 32nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed New User Approve (Unknown): 2.4

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownNew User Approve2.4 to before 2.42.4Patch availableCNA
  • New User Approve VendorUnknown Affected 2.4 to before 2.4 Fixed in 2.4 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:wpexperts:new_user_approve:*:*:*:*:*:wordpress:*:*before 2.4VulnerableWPExperts
  • cpe:2.3:a:wpexperts:new_user_approve:*:*:*:*:*:wordpress:*:* Versions before 2.4 Vulnerable ·WPExperts

Remediation

  • Fix · CNA New User Approve (Unknown) Fixed in 2.4

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-1625
  2. 2026-10-03 Alias added: GHSA-573v-fpj9-9qh6

References

  • TI-2023-27805 WordPress New User Approve Plugin <= 2.5.1 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8

Sources