FormCraft Basic < 1.2.6 - Admin+ Stored Cross Site Scripting
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The FormCraft WordPress plugin before 1.2.6 does not sanitise and escape Field Labels, allowing high privilege users such as admin to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Why it matters now
EPSS 0.00598 48th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed FormCraft – Contact Form Builder for WordPress (Unknown): 1.2.6
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | FormCraft – Contact Form Builder for WordPress | 1.2.6 to before 1.2.6 | 1.2.6 | Patch available | CNA |
- FormCraft – Contact Form Builder for WordPress VendorUnknown Affected 1.2.6 to before 1.2.6 Fixed in 1.2.6 Patch available CNA
Remediation
- Fix · CNA FormCraft – Contact Form Builder for WordPress (Unknown) Fixed in 1.2.6
Timeline
- 2026-10-02 Threatist record created from CVE-2022-1647
- 2026-10-03 Alias added: GHSA-hgx3-q35p-hgmv
References
More nCrafts Formcraft vulnerabilities
- TI-2023-02422 FormCraft Premium < 3.9.7 - Admin+ SQLi CVSS 3.1HIGH 7.2
- TI-2019-04216 Cross-site request forgery in nCrafts FormCraft CVSS 3.0HIGH 8.8
- TI-2013-05877 SQL injection vulnerability in form.php in the FormCraft plugin 1.3.7 and earlier for… CVSS 2.0HIGH 7.5
- TI-2019-11285 The formcraft-form-builder plugin before 1.2.2 for WordPress has CSRF. CVSS 3.0HIGH 8.8
- TI-2025-00689 FormCraft - Premium WordPress Form Builder <= 3.9.11 - Unauthenticated Stored Cross-Site Scripting via SVG File Upload CVSS 3.1HIGH 7.2
- TI-2023-08892 WordPress FormCraft Plugin <= 1.2.6 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
Sources
- CVE-2022-1647 · CVE Program
- CVE-2022-1647 · NVD
- FIRST EPSS
- GHSA-hgx3-q35p-hgmv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences