Gallery < 2.0.0 - Reflected Cross-Site Scripting
Priority LOW 31CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Gallery WordPress plugin before 2.0.0 does not sanitise and escape a parameter before outputting it back in the response of an AJAX action (available to both unauthenticated and authenticated users), leading to a Reflected Cross-Site Scripting issue
Why it matters now
EPSS 0.01768 78th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Gallery – Image and Video Gallery with Thumbnails (Unknown): 2.0.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Gallery – Image and Video Gallery with Thumbnails | 2.0.0 to before 2.0.0 | 2.0.0 | Patch available | CNA |
- Gallery – Image and Video Gallery with Thumbnails VendorUnknown Affected 2.0.0 to before 2.0.0 Fixed in 2.0.0 Patch available CNA
Remediation
- Fix · CNA Gallery – Image and Video Gallery with Thumbnails (Unknown) Fixed in 2.0.0
Timeline
- 2026-10-02 Threatist record created from CVE-2022-1946
- 2026-10-03 Alias added: GHSA-rjrj-j2x7-8hj2
References
More wpdevart Gallery vulnerabilities
- TI-2024-23619 WordPress Gallery – Image and Video Gallery with Thumbnails plugin <= 2.0.3 - SQL Injection vulnerability CVSS 3.1HIGH 8.8
- TI-2024-20274 Cross-site scripting in wpdevart Responsive Image Gallery, Gallery Album CVSS 3.1HIGH 7.1
- TI-2023-24431 WordPress Responsive Image Gallery, Gallery Album Plugin <= 2.0.3 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
- TI-2024-20509 WordPress Gallery – Image and Video Gallery with Thumbnails plugin <= 2.0.3 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
- TI-2024-25042 WordPress Gallery – Image and Video Gallery with Thumbnails plugin <= 2.0.3 - Broken Access Control vulnerability CVSS 3.1MEDIUM 6.3
- TI-2023-24432 WordPress Gallery – Image and Video Gallery with Thumbnails plugin <= 2.0.3 - Broken Access Control vulnerability CVSS 3.1MEDIUM 5.4
Sources
- CVE-2022-1946 · CVE Program
- CVE-2022-1946 · NVD
- FIRST EPSS
- GHSA-rjrj-j2x7-8hj2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences