Read the docs
TI-2022-01845 Aliases CVE-2022-1990GHSA-xqgh-cm65-m6gj

Nested Pages < 3.1.21 - Admin+ Stored Cross Site Scripting

Priority MEDIUM 55CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The Nested Pages WordPress plugin before 3.1.21 does not escape and sanitize the some of its settings, which could allow high privilege users to perform Stored Cross-Site Scripting attacks when the unfiltered_html is disallowed

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00667 52nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Nested Pages (Unknown): 3.1.21

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownNested Pages3.1.21 to before 3.1.213.1.21Patch availableCNA
  • Nested Pages VendorUnknown Affected 3.1.21 to before 3.1.21 Fixed in 3.1.21 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:kylephillips:nested_pages:*:*:*:*:*:wordpress:*:*before 3.1.21VulnerableKyle Phillips
  • cpe:2.3:a:kylephillips:nested_pages:*:*:*:*:*:wordpress:*:* Versions before 3.1.21 Vulnerable ·Kyle Phillips

Remediation

  • Fix · CNA Nested Pages (Unknown) Fixed in 3.1.21

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-1990
  2. 2026-10-03 Alias added: GHSA-xqgh-cm65-m6gj

References

  • TI-2025-00609 Nested Pages < 3.2.13 - Contributor+ Stored XSS CVSS 3.1MEDIUM 4.8
  • TI-2024-08125 Nested Pages <= 3.2.8 - Editor+ Stored XSS CVSS 3.1MEDIUM 4.8
  • TI-2024-05508 Nested Pages <= 3.2.7 - Cross-Site Request Forgery to Local File Inclusion CVSS 3.1HIGH 8.8
  • TI-2021-15949 Nested Pages <= 3.1.15 Cross-Site Request Forgery to Arbitrary Post Deletion and Modification CVSS 3.1HIGH 8.1
  • TI-2021-15950 Nested Pages <= 3.1.15 Open Redirect CVSS 3.1MEDIUM 6.1
  • TI-2023-26854 WordPress Nested Pages Plugin <= 3.2.6 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9
See all 7 →

Sources