Nested Pages <= 3.2.8 - Editor+ Stored XSS
Priority MEDIUM 55CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Nested Pages WordPress plugin before 3.2.9 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00355 29th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Nested Pages (Unknown): 3.2.9
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Nested Pages | before 3.2.9 | 3.2.9 | Patch available | CNA |
- Nested Pages VendorUnknown Affected before 3.2.9 Fixed in 3.2.9 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:kylephillips:nested_pages:*:*:*:*:*:wordpress:*:* | before 3.2.9 | Vulnerable | Kyle Phillips |
- cpe:2.3:a:kylephillips:nested_pages:*:*:*:*:*:wordpress:*:* Versions before 3.2.9 Vulnerable ·Kyle Phillips
Remediation
- Fix · CNA Nested Pages (Unknown) Fixed in 3.2.9
Timeline
- 2026-10-02 Threatist record created from CVE-2024-8759
- 2026-10-03 Alias added: GHSA-mqjj-6j4c-9xw9
References
More Kyle Phillips Nested Pages vulnerabilities
- TI-2025-00609 Nested Pages < 3.2.13 - Contributor+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2022-01845 Nested Pages < 3.1.21 - Admin+ Stored Cross Site Scripting CVSS 3.1MEDIUM 4.8
- TI-2024-05508 Nested Pages <= 3.2.7 - Cross-Site Request Forgery to Local File Inclusion CVSS 3.1HIGH 8.8
- TI-2021-15949 Nested Pages <= 3.1.15 Cross-Site Request Forgery to Arbitrary Post Deletion and Modification CVSS 3.1HIGH 8.1
- TI-2021-15950 Nested Pages <= 3.1.15 Open Redirect CVSS 3.1MEDIUM 6.1
- TI-2023-26854 WordPress Nested Pages Plugin <= 3.2.6 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9
Sources
- CVE-2024-8759 · CVE Program
- CVE-2024-8759 · NVD
- FIRST EPSS
- GHSA-mqjj-6j4c-9xw9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences