In Octopus Server after version 2022.1.1495 and before 2022.1.2647 if private spaces were…
Priority LOW 35Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
In Octopus Server after version 2022.1.1495 and before 2022.1.2647 if private spaces were enabled via the experimental feature flag all new users would have access to the Script Console within their private space.
Why it matters now
EPSS 0.00927 60th percentileScored 2026-11-07
Fix Fixed Octopus Server (Octopus Deploy): 2022.1.2647
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Octopus Deploy | Octopus Server | 2022.1.1495 and later; before 2022.1.2647 | 2022.1.2647 | Patch available | CNA |
- Octopus Server VendorOctopus Deploy Affected 2022.1.1495 and later; before 2022.1.2647 Fixed in 2022.1.2647 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:octopus:octopus_deploy:*:*:*:*:*:*:*:* | 2022.1.1495 to before 2022.1.2647 | Vulnerable | Octopus Deploy |
| cpe:2.3:o:linux:linux_kernel:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Linux |
| cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Microsoft |
- cpe:2.3:a:octopus:octopus_deploy:*:*:*:*:*:*:*:* Versions 2022.1.1495 to before 2022.1.2647 Vulnerable ·Octopus Deploy
- cpe:2.3:o:linux:linux_kernel:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Linux
- cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Microsoft
Remediation
- Fix · CNA Octopus Server (Octopus Deploy) Fixed in 2022.1.2647
Timeline
- 2026-10-02 Threatist record created from CVE-2022-2013
- 2026-10-03 Alias added: GHSA-qrpm-597h-q27g
References
More Octopus Deploy vulnerabilities
- TI-2020-08583 In Octopus Deploy before 2020.1.5, for customers running on-premises Active Directory… CVSS 3.1HIGH 8.8
- TI-2018-04116 An issue was discovered in Octopus Deploy before 4.1.9. CVSS 3.0HIGH 8.8
- TI-2018-03438 In Octopus Deploy versions 3.2.11 - 4.1.5 (fixed in 4.1.6), an authenticated user with… CVSS 3.0HIGH 8.8
- TI-2017-12930 In Octopus Deploy before 4.1.3, the machine update process doesn't check that the user… CVSS 3.0HIGH 8.8
- TI-2019-08703 In Octopus Deploy 2019.1.0 through 2019.3.1 and 2019.4.0 through 2019.4.5, an… CVSS 3.0HIGH 8.1
- TI-2020-15818 In Octopus Deploy 3.1.0 to 2020.4.0, certain scripts can reveal sensitive information to the user in the task logs. CVSS 3.1HIGH 7.5
Sources
- CVE-2022-2013 · CVE Program
- CVE-2022-2013 · NVD
- FIRST EPSS
- GHSA-qrpm-597h-q27g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences