WP Database Backup < 5.9 - Admin+ Stored Cross-Site Scripting
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The WP Database Backup WordPress plugin before 5.9 does not escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks when the unfiltered_html capability is disallowed (for example in multisite setup)
Why it matters now
EPSS 0.00518 44th percentileScored 2026-11-07
Fix Fixed WP Database Backup (Unknown): 5.9
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WP Database Backup | 5.9 to before 5.9 | 5.9 | Patch available | CNA |
- WP Database Backup VendorUnknown Affected 5.9 to before 5.9 Fixed in 5.9 Patch available CNA
Remediation
- Fix · CNA WP Database Backup (Unknown) Fixed in 5.9
Timeline
- 2026-10-02 Threatist record created from CVE-2022-2271
- 2026-10-03 Alias added: GHSA-x44q-mwr9-fc57
References
More Wpseeds Wp Database Backup vulnerabilities
- TI-2019-15278 WP Database Backup < 5.2 - Unauthenticated OS Command Injection CVSS 3.1CRITICAL 9.8
- TI-2016-08914 The wp-database-backup plugin before 4.3.1 for WordPress has CSRF. CVSS 3.0HIGH 8.8
- TI-2016-08912 The wp-database-backup plugin before 4.3.3 for WordPress has CSRF. CVSS 3.1HIGH 8.8
- TI-2020-05848 The WP Database Backup plugin through 5.5 for WordPress stores downloads by default… CVSS 3.1HIGH 7.5
- TI-2019-11147 The wp-database-backup plugin before 5.1.2 for WordPress has XSS. CVSS 3.1MEDIUM 6.1
- TI-2016-08913 The wp-database-backup plugin before 4.3.1 for WordPress has XSS. CVSS 3.1MEDIUM 6.1
Sources
- CVE-2022-2271 · CVE Program
- CVE-2022-2271 · NVD
- FIRST EPSS
- GHSA-x44q-mwr9-fc57 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences