weForms < 1.6.14 - Admin+ Stored Cross-Site Scripting
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The weForms WordPress plugin before 1.6.14 does not sanitise and escape its settings, allowing high privilege users such as admin to perform cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Why it matters now
EPSS 0.00622 50th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed weForms – Easy Drag & Drop Contact Form Builder For WordPress (Unknown): 1.6.14
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | weForms – Easy Drag & Drop Contact Form Builder For WordPress | 1.6.14 to before 1.6.14 | 1.6.14 | Patch available | CNA |
- weForms – Easy Drag & Drop Contact Form Builder For WordPress VendorUnknown Affected 1.6.14 to before 1.6.14 Fixed in 1.6.14 Patch available CNA
Remediation
- Fix · CNA weForms – Easy Drag & Drop Contact Form Builder For WordPress (Unknown) Fixed in 1.6.14
Timeline
- 2026-10-02 Threatist record created from CVE-2022-2395
- 2026-10-03 Alias added: GHSA-j7m7-j5hp-65r3
- 2026-11-06 EPSS moved to the 50th–90th percentile
References
More Weforms vulnerabilities
- TI-2020-14319 WeForms Wordpress Plugin 1.4.7 allows CSV injection via a form's entry. CVSS 3.1CRITICAL 9.8
- TI-2024-20236 WordPress weForms plugin <= 1.6.20 - Broken Access Control vulnerability CVSS 3.1CRITICAL 9.1
- TI-2023-28176 WordPress weForms plugin <= 1.6.18 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
- TI-2024-00352 weForms <= 1.6.21 - Unauthenticated Stored Cross-Site Scripting via Referer CVSS 3.1HIGH 7.2
- TI-2023-27799 WordPress weForms Plugin <= 1.6.17 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9
Sources
- CVE-2022-2395 · CVE Program
- CVE-2022-2395 · NVD
- FIRST EPSS
- GHSA-j7m7-j5hp-65r3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences