Team members could access sensitive information of other users via an API call
Priority LOW 30CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
Unrestricted information disclosure of all users in Mattermost version 6.7.0 and earlier allows team members to access some sensitive information by directly accessing the APIs.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00828 57th percentileScored 2026-11-07
Fix Fixed github.com/mattermost/mattermost-server/v6 (Go): 6.3.9, 6.5.2, 6.6.2 +1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Mattermost | Mattermost | 6.7.x 6.7.0; 6.x – 6.3.8; 6.5.x – 6.5.1; 6.6.x – 6.6.1 | — | No fix listed | CNA |
| — | github.com/mattermost/mattermost-server/v6 (Go) | before 6.3.9 | 6.3.9 | Patch available | GHSA-7ggc-5r84-xf54 |
| — | github.com/mattermost/mattermost-server/v6 (Go) | 6.4.0 to before 6.5.2 | 6.5.2 | Patch available | GHSA-7ggc-5r84-xf54 |
| — | github.com/mattermost/mattermost-server/v6 (Go) | 6.6.0 to before 6.6.2 | 6.6.2 | Patch available | GHSA-7ggc-5r84-xf54 |
| — | github.com/mattermost/mattermost-server/v6 (Go) | 6.7.0 to before 6.7.1 | 6.7.1 | Patch available | GHSA-7ggc-5r84-xf54 |
- Mattermost VendorMattermost Affected 6.7.x 6.7.0; 6.x – 6.3.8; 6.5.x – 6.5.1; 6.6.x – 6.6.1 Fixed in — No fix listed CNA
- github.com/mattermost/mattermost-server/v6 (Go) Vendor— Affected before 6.3.9 Fixed in 6.3.9 Patch available GHSA-7ggc-5r84-xf54
- github.com/mattermost/mattermost-server/v6 (Go) Vendor— Affected 6.4.0 to before 6.5.2 Fixed in 6.5.2 Patch available GHSA-7ggc-5r84-xf54
- github.com/mattermost/mattermost-server/v6 (Go) Vendor— Affected 6.6.0 to before 6.6.2 Fixed in 6.6.2 Patch available GHSA-7ggc-5r84-xf54
- github.com/mattermost/mattermost-server/v6 (Go) Vendor— Affected 6.7.0 to before 6.7.1 Fixed in 6.7.1 Patch available GHSA-7ggc-5r84-xf54
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* | before 6.3.9; 6.4.0 to before 6.5.2 | Vulnerable | Mattermost |
| cpe:2.3:a:mattermost:mattermost_server:6.6.0:*:*:*:*:*:*:* | 6.6.0 | Vulnerable | Mattermost |
| cpe:2.3:a:mattermost:mattermost_server:6.6.1:*:*:*:*:*:*:* | 6.6.1 | Vulnerable | Mattermost |
| cpe:2.3:a:mattermost:mattermost_server:6.7.0:*:*:*:*:*:*:* | 6.7.0 | Vulnerable | Mattermost |
- cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* Versions before 6.3.9; 6.4.0 to before 6.5.2 Vulnerable ·Mattermost
- cpe:2.3:a:mattermost:mattermost_server:6.6.0:*:*:*:*:*:*:* Versions 6.6.0 Vulnerable ·Mattermost
- cpe:2.3:a:mattermost:mattermost_server:6.6.1:*:*:*:*:*:*:* Versions 6.6.1 Vulnerable ·Mattermost
- cpe:2.3:a:mattermost:mattermost_server:6.7.0:*:*:*:*:*:*:* Versions 6.7.0 Vulnerable ·Mattermost
Remediation
- Fix · GHSA-7ggc-5r84-xf54 github.com/mattermost/mattermost-server/v6 (Go) Fixed in 6.3.9 Advisory →
- Fix · GHSA-7ggc-5r84-xf54 github.com/mattermost/mattermost-server/v6 (Go) Fixed in 6.5.2 Advisory →
- Fix · GHSA-7ggc-5r84-xf54 github.com/mattermost/mattermost-server/v6 (Go) Fixed in 6.6.2 Advisory →
- Fix · GHSA-7ggc-5r84-xf54 github.com/mattermost/mattermost-server/v6 (Go) Fixed in 6.7.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-2401
- 2026-10-03 Alias added: GHSA-7ggc-5r84-xf54
References
More Mattermost Server vulnerabilities
- TI-2025-18933 Arbitrary file read in Mattermost Boards via import & export board archive CVSS 3.1CRITICAL 9.9
- TI-2025-04465 Path Traversal Leading to RCE by Any Authenticated Mattermost User CVSS 3.1CRITICAL 9.9
- TI-2017-14068 An issue was discovered in Mattermost Server before 3.6.2. CVSS 3.1CRITICAL 9.8
- TI-2017-14060 An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7. CVSS 3.1CRITICAL 9.8
- TI-2017-14048 An issue was discovered in Mattermost Server before 4.1.0, 4.0.4, and 3.10.3. CVSS 3.1CRITICAL 9.8
- TI-2025-14360 Arbitrary file read via block duplication in Mattermost Boards CVSS 3.1CRITICAL 9.9
Sources
- CVE-2022-2401 · CVE Program
- CVE-2022-2401 · NVD
- FIRST EPSS
- GHSA-7ggc-5r84-xf54 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences