Read the docs
TI-2022-02236 Aliases CVE-2022-2421GHSA-qm95-pgcg-qqfq

Socket.io - Improper type validation in attachment parsing

Priority MEDIUM 52CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
SQL injection
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-89.

Summary

Due to improper type validation in attachment parsing the Socket.io js library, it is possible to overwrite the _placeholder object which allows an attacker to place references to functions at arbitrary places in the resulting query object.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01431 73rd percentileScored 2026-11-07
Fix Fixed Socket.io-Parser (Socket.io): 4.2.1socket.io-parser (npm): 4.0.5, 4.2.1, 3.3.3 +1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
@socket.ioSocket.io-Parser4.x to before 4.2.14.2.1Patch availableCNA
—socket.io-parser (npm)4.0.0 to before 4.0.54.0.5Patch availableGHSA-qm95-pgcg-qqfq
—socket.io-parser (npm)4.1.0 to before 4.2.14.2.1Patch availableGHSA-qm95-pgcg-qqfq
—socket.io-parser (npm)before 3.3.33.3.3Patch availableGHSA-qm95-pgcg-qqfq
—socket.io-parser (npm)3.4.0 to before 3.4.23.4.2Patch availableGHSA-qm95-pgcg-qqfq
  • Socket.io-Parser Vendor@socket.io Affected 4.x to before 4.2.1 Fixed in 4.2.1 Patch available CNA
  • socket.io-parser (npm) Vendor— Affected 4.0.0 to before 4.0.5 Fixed in 4.0.5 Patch available GHSA-qm95-pgcg-qqfq
  • socket.io-parser (npm) Vendor— Affected 4.1.0 to before 4.2.1 Fixed in 4.2.1 Patch available GHSA-qm95-pgcg-qqfq
  • socket.io-parser (npm) Vendor— Affected before 3.3.3 Fixed in 3.3.3 Patch available GHSA-qm95-pgcg-qqfq
  • socket.io-parser (npm) Vendor— Affected 3.4.0 to before 3.4.2 Fixed in 3.4.2 Patch available GHSA-qm95-pgcg-qqfq

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:socket:socket.io-parser:*:*:*:*:*:node.js:*:*before 3.3.3; 3.4.0 to before 3.4.2; 4.0.0 to before 4.0.5; 4.1.0 to before 4.2.1Vulnerablesocketio
  • cpe:2.3:a:socket:socket.io-parser:*:*:*:*:*:node.js:*:* Versions before 3.3.3; 3.4.0 to before 3.4.2; 4.0.0 to before 4.0.5; 4.1.0 to before 4.2.1 Vulnerable ·socketio

Remediation

  • Fix · CNA Socket.io-Parser (Socket.io) Fixed in 4.2.1
  • Fix · GHSA-qm95-pgcg-qqfq socket.io-parser (npm) Fixed in 4.0.5 Advisory →
  • Fix · GHSA-qm95-pgcg-qqfq socket.io-parser (npm) Fixed in 4.2.1 Advisory →
  • Fix · GHSA-qm95-pgcg-qqfq socket.io-parser (npm) Fixed in 3.3.3 Advisory →
  • Fix · GHSA-qm95-pgcg-qqfq socket.io-parser (npm) Fixed in 3.4.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-2421
  2. 2026-10-03 Alias added: GHSA-qm95-pgcg-qqfq

References

  • TI-2026-65444 Socket.IO: Prototype Pollution via Unsafe Client Session Lookup CVSS 3.1HIGH 7.5

Sources