WooCommerce PDF Invoices & Packing Slips < 3.0.1 - Reflected Cross-Site Scripting
Priority LOW 28CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The WooCommerce PDF Invoices & Packing Slips WordPress plugin before 3.0.1 does not sanitise and escape some parameters before outputting them back in an attributes of an admin page, leading to Reflected Cross-Site Scripting.
Why it matters now
EPSS 0.00681 52nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed WooCommerce PDF Invoices & Packing Slips (Unknown): 3.0.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WooCommerce PDF Invoices & Packing Slips | 2.14.0 and later; 3.0.1 to before 3.0.1 | 3.0.1 | Patch available | CNA |
- WooCommerce PDF Invoices & Packing Slips VendorUnknown Affected 2.14.0 and later; 3.0.1 to before 3.0.1 Fixed in 3.0.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wpovernight:woocommerce_pdf_invoices\&_packing_slips:*:*:*:*:*:wordpress:*:* | 2.14.0 to before 3.0.1 | Vulnerable | wpovernight |
- cpe:2.3:a:wpovernight:woocommerce_pdf_invoices\&_packing_slips:*:*:*:*:*:wordpress:*:* Versions 2.14.0 to before 3.0.1 Vulnerable ·wpovernight
Remediation
- Fix · CNA WooCommerce PDF Invoices & Packing Slips (Unknown) Fixed in 3.0.1
Timeline
- 2026-10-02 Threatist record created from CVE-2022-2537
- 2026-10-03 Alias added: GHSA-m267-8vw8-g9w3
References
More wpovernight Woocommerce Pdf Invoices& Packing Slips vulnerabilities
- TI-2024-02851 PDF Invoices & Packing Slips for WooCommerce <= 3.8.0 - Unauthenticated Stored Cross-Site Scripting CVSS 3.1HIGH 7.2
- TI-2025-18116 Unrestricted Access to PDF Documents via URL Manipulation in woocommerce-pdf-invoices-packing-slips CVSS 4.0MEDIUM 6.3
- TI-2024-14748 WordPress WooCommerce PDF Invoices & Packing Slips Plugin <= 3.7.5 is vulnerable to SQL Injection CVSS 3.1HIGH 7.6
- TI-2024-02853 PDF Invoices & Packing Slips for WooCommerce <= 3.8.0 - Unauthenticated Server-Side Request Forgery CVSS 3.1HIGH 7.2
- TI-2022-01936 WooCommerce PDF Invoices & Packing Slips < 2.16.0 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2017-13679 The woocommerce-pdf-invoices-packing-slips plugin before 2.0.13 for WordPress has XSS via… CVSS 3.0MEDIUM 6.1
Sources
- CVE-2022-2537 · CVE Program
- CVE-2022-2537 · NVD
- FIRST EPSS
- GHSA-m267-8vw8-g9w3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences