WP Hide & Security Enhancer < 1.8 - Reflected Cross-Site Scripting
Priority LOW 28CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The WP Hide & Security Enhancer WordPress plugin before 1.8 does not escape a parameter before outputting it back in an attribute of a backend page, leading to a Reflected Cross-Site Scripting
Why it matters now
EPSS 0.00681 52nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed WP Hide & Security Enhancer (Unknown): 1.8
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WP Hide & Security Enhancer | 1.8 to before 1.8 | 1.8 | Patch available | CNA |
- WP Hide & Security Enhancer VendorUnknown Affected 1.8 to before 1.8 Fixed in 1.8 Patch available CNA
Remediation
- Fix · CNA WP Hide & Security Enhancer (Unknown) Fixed in 1.8
Timeline
- 2026-10-02 Threatist record created from CVE-2022-2538
- 2026-10-03 Alias added: GHSA-4mf2-h833-wrvr
References
Sources
- CVE-2022-2538 · CVE Program
- CVE-2022-2538 · NVD
- FIRST EPSS
- GHSA-4mf2-h833-wrvr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences