WBW Currency Switcher for WooCommerce < 1.6.6 - Admin+ Stored XSS
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The WBW Currency Switcher for WooCommerce WordPress plugin before 1.6.6 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Why it matters now
EPSS 0.00597 48th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed WBW Currency Switcher for WooCommerce (Unknown): 1.6.6
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WBW Currency Switcher for WooCommerce | 1.6.6 to before 1.6.6 | 1.6.6 | Patch available | CNA |
- WBW Currency Switcher for WooCommerce VendorUnknown Affected 1.6.6 to before 1.6.6 Fixed in 1.6.6 Patch available CNA
Remediation
- Fix · CNA WBW Currency Switcher for WooCommerce (Unknown) Fixed in 1.6.6
Timeline
- 2026-10-02 Threatist record created from CVE-2022-2575
- 2026-10-03 Alias added: GHSA-phv8-5j8g-hg5p
References
Sources
- CVE-2022-2575 · CVE Program
- CVE-2022-2575 · NVD
- FIRST EPSS
- GHSA-phv8-5j8g-hg5p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences