Top Bar < 3.0.4 - Admin+ Stored Cross-Site Scripting
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Top Bar WordPress plugin before 3.0.4 does not sanitise and escape some of its settings before outputting them in frontend pages, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Why it matters now
EPSS 0.00644 51st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Top Bar (Unknown): 3.0.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Top Bar | 3.0.4 to before 3.0.4 | 3.0.4 | Patch available | CNA |
- Top Bar VendorUnknown Affected 3.0.4 to before 3.0.4 Fixed in 3.0.4 Patch available CNA
Remediation
- Fix · CNA Top Bar (Unknown) Fixed in 3.0.4
Timeline
- 2026-10-02 Threatist record created from CVE-2022-2629
- 2026-10-03 Alias added: GHSA-q6g9-37mh-p56c
- 2026-10-27 EPSS moved to the 50th–90th percentile
References
More WP Darko Top Bar vulnerabilities
- TI-2024-01543 Top Bar < 3.0.5 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
Sources
- CVE-2022-2629 · CVE Program
- CVE-2022-2629 · NVD
- FIRST EPSS
- GHSA-q6g9-37mh-p56c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences