Top Bar < 3.0.5 - Admin+ Stored XSS
Priority MEDIUM 55CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Top Bar WordPress plugin before 3.0.5 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00441 38th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Top Bar (Unknown): 3.0.5
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Top Bar | before 3.0.5 | 3.0.5 | Patch available | CNA |
- Top Bar VendorUnknown Affected before 3.0.5 Fixed in 3.0.5 Patch available CNA
Remediation
- Fix · CNA Top Bar (Unknown) Fixed in 3.0.5
Timeline
- 2026-10-02 Threatist record created from CVE-2024-1660
- 2026-10-03 Alias added: GHSA-hhr3-pmv2-95vx
References
More WP Darko Top Bar vulnerabilities
- TI-2022-02431 Top Bar < 3.0.4 - Admin+ Stored Cross-Site Scripting CVSS 3.1MEDIUM 4.8
Sources
- CVE-2024-1660 · CVE Program
- CVE-2024-1660 · NVD
- FIRST EPSS
- GHSA-hhr3-pmv2-95vx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences