In affected versions of Octopus Deploy it is possible to bypass rate limiting on login using null bytes.
Priority MEDIUM 44Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
In affected versions of Octopus Deploy it is possible to bypass rate limiting on login using null bytes.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00853 58th percentileScored 2026-11-07
Fix Fixed Octopus Server (Octopus Deploy): 2022.2.8277, 2022.3.10586, 2022.4.1371
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Octopus Deploy | Octopus Server | 3.0 and later; before 2022.2.8277; 2022.3.348 and later; before 2022.3.10586; 2022.4.791 and later; before 2022.4.1371 | 2022.2.8277, 2022.3.10586, 2022.4.1371 | Patch available | CNA |
- Octopus Server VendorOctopus Deploy Affected 3.0 and later; before 2022.2.8277; 2022.3.348 and later; before 2022.3.10586; 2022.4.791 and later; before 2022.4.1371 Fixed in 2022.2.8277, 2022.3.10586, 2022.4.1371 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:octopus:octopus_server:*:*:*:*:*:*:*:* | 3.0 to before 2022.2.8277; 2022.3.348 to before 2022.3.10405; 2022.4.791 to before 2022.4.1371 | Vulnerable | Octopus Deploy |
| cpe:2.3:o:linux:linux_kernel:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Linux |
| cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Microsoft |
- cpe:2.3:a:octopus:octopus_server:*:*:*:*:*:*:*:* Versions 3.0 to before 2022.2.8277; 2022.3.348 to before 2022.3.10405; 2022.4.791 to before 2022.4.1371 Vulnerable ·Octopus Deploy
- cpe:2.3:o:linux:linux_kernel:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Linux
- cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Microsoft
Remediation
- Fix · CNA Octopus Server (Octopus Deploy) Fixed in 2022.2.8277, 2022.3.10586, 2022.4.1371
Timeline
- 2026-10-02 Threatist record created from CVE-2022-2778
- 2026-10-03 Alias added: GHSA-xh2c-fh83-6hgx
References
More Octopus Deploy Octopus Server vulnerabilities
- TI-2018-13353 In Octopus Deploy 2018.8.0 through 2018.9.x before 2018.9.1, an authenticated user with… CVSS 3.0HIGH 8.8
- TI-2022-02375 Improper authentication in Octopus Server CVSS 3.1CRITICAL 9.8
- TI-2022-02579 Insufficient session expiration in Octopus Server CVSS 3.1CRITICAL 9.1
- TI-2018-08066 In Octopus Deploy 2018.4.4 through 2018.5.1, Octopus variables that are sourced from the… CVSS 3.0CRITICAL 9.8
- TI-2022-03678 In affected versions of Octopus Deploy it is possible for a user to introduce code via offline package creation CVSS 3.1HIGH 8.8
- TI-2022-02673 Unrestricted file upload in Octopus Server CVSS 3.1HIGH 7.5
Sources
- CVE-2022-2778 · CVE Program
- CVE-2022-2778 · NVD
- FIRST EPSS
- GHSA-xh2c-fh83-6hgx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences