Insufficient session expiration in Octopus Server
Priority MEDIUM 48CWE-613Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-613.
Summary
In affected versions of Octopus Server it is possible for a session token to be valid indefinitely due to improper validation of the session token parameters.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0065 51st percentileScored 2026-11-07
Fix Fixed Octopus Server (Octopus Deploy): 2022.2.8351, 2022.3.10586, 2022.4.2898
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Octopus Deploy | Octopus Server | 0.9 and later; before 2022.2.8351; 2022.3.348 and later; before 2022.3.10586; 2022.4.791 and later; before 2022.4.2898 | 2022.2.8351, 2022.3.10586, 2022.4.2898 | Patch available | CNA |
- Octopus Server VendorOctopus Deploy Affected 0.9 and later; before 2022.2.8351; 2022.3.348 and later; before 2022.3.10586; 2022.4.791 and later; before 2022.4.2898 Fixed in 2022.2.8351, 2022.3.10586, 2022.4.2898 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:octopus:octopus_server:*:*:*:*:*:*:*:* | before 2022.2.8351; 2022.3.0 to before 2022.3.10586; 2022.4.0 to before 2022.4.2898 | Vulnerable | Octopus Deploy |
- cpe:2.3:a:octopus:octopus_server:*:*:*:*:*:*:*:* Versions before 2022.2.8351; 2022.3.0 to before 2022.3.10586; 2022.4.0 to before 2022.4.2898 Vulnerable ·Octopus Deploy
Remediation
- Fix · CNA Octopus Server (Octopus Deploy) Fixed in 2022.2.8351, 2022.3.10586, 2022.4.2898
Timeline
- 2026-10-02 Threatist record created from CVE-2022-2782
- 2026-10-03 Alias added: GHSA-wvgj-4785-cm7h
- 2026-10-23 EPSS moved to the 50th–90th percentile
References
More Octopus Deploy Octopus Server vulnerabilities
- TI-2018-13353 In Octopus Deploy 2018.8.0 through 2018.9.x before 2018.9.1, an authenticated user with… CVSS 3.0HIGH 8.8
- TI-2022-02375 Improper authentication in Octopus Server CVSS 3.1CRITICAL 9.8
- TI-2018-08066 In Octopus Deploy 2018.4.4 through 2018.5.1, Octopus variables that are sourced from the… CVSS 3.0CRITICAL 9.8
- TI-2022-02575 In affected versions of Octopus Deploy it is possible to bypass rate limiting on login using null bytes. CVSS 3.1CRITICAL 9.8
- TI-2022-03678 In affected versions of Octopus Deploy it is possible for a user to introduce code via offline package creation CVSS 3.1HIGH 8.8
- TI-2022-02673 Unrestricted file upload in Octopus Server CVSS 3.1HIGH 7.5
Sources
- CVE-2022-2782 · CVE Program
- CVE-2022-2782 · NVD
- FIRST EPSS
- GHSA-wvgj-4785-cm7h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences