Soledad < 8.2.5 - Reflected Cross-site Scripting
Priority LOW 28CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The soledad WordPress theme before 8.2.5 does not sanitise the {id,datafilter[type],...} parameters in its penci_more_slist_post_ajax AJAX action, leading to a Reflected Cross-Site Scripting (XSS) vulnerability.
Why it matters now
EPSS 0.00618 49th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed soledad (Unknown): 8.2.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | soledad | 8.2.5 to before 8.2.5 | 8.2.5 | Patch available | CNA |
- soledad VendorUnknown Affected 8.2.5 to before 8.2.5 Fixed in 8.2.5 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pencidesign:soledad:*:*:*:*:*:wordpress:*:* | before 8.2.5 | Vulnerable | PenciDesign |
- cpe:2.3:a:pencidesign:soledad:*:*:*:*:*:wordpress:*:* Versions before 8.2.5 Vulnerable ·PenciDesign
Remediation
- Fix · CNA soledad (Unknown) Fixed in 8.2.5
Timeline
- 2026-10-02 Threatist record created from CVE-2022-3209
- 2026-10-03 Alias added: GHSA-c975-8p92-pprh
References
More PenciDesign Soledad vulnerabilities
- TI-2023-27230 WordPress Soledad Theme <= 8.4.1 is vulnerable to PHP Object Injection CVSS 3.1CRITICAL 9.8
- TI-2023-27229 WordPress Soledad Theme <= 8.4.1 is vulnerable to SQL Injection CVSS 3.1HIGH 8.5
- TI-2024-20739 WordPress Soledad theme <= 8.4.2 - Authenticated Broken Access Control vulnerability CVSS 3.1HIGH 7.1
- TI-2024-20740 WordPress Soledad theme <= 8.4.2 - Unauthenticated Broken Access Control vulnerability CVSS 3.1MEDIUM 6.5
- TI-2023-27231 WordPress Soledad Theme <= 8.4.1 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
- TI-2022-20163 WordPress Soledad premium theme <= 8.2.5 - Auth. Cross-Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 5.4
Sources
- CVE-2022-3209 · CVE Program
- CVE-2022-3209 · NVD
- FIRST EPSS
- GHSA-c975-8p92-pprh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences