WPtouch < 4.3.45 - Admin+ Arbitrary File Upload
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The WPtouch WordPress plugin before 4.3.45 does not properly validate images to be uploaded, allowing high privilege users such as admin to upload arbitrary files on the server even when they should not be allowed to (for example in multisite setup)
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WPtouch | before 4.3.45 | 4.3.45 | Patch available | CNA |
- WPtouch VendorUnknown Affected before 4.3.45 Fixed in 4.3.45 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:bravenewcode:wptouch:*:*:*:*:*:wordpress:*:* | before 4.3.45 | Vulnerable | Bravenewcode |
- cpe:2.3:a:bravenewcode:wptouch:*:*:*:*:*:wordpress:*:* Versions before 4.3.45 Vulnerable ·Bravenewcode
Remediation
- Fix · CNA WPtouch (Unknown) Fixed in 4.3.45
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
WPtouch 4.3.45
2 records Highest priority Priority HIGH 1 HIGH, 1 MEDIUM
Other records, highest priority first
- TI-2022-03155 WPtouch < 4.3.45 - Admin+ PHP Object InjectionPriority MEDIUM 42
Timeline
- 2026-10-02 Threatist record created from CVE-2022-3416
- 2026-10-03 Alias added: GHSA-m7v9-fq6q-w2wp
References
More Bravenewcode Wptouch vulnerabilities
- TI-2022-03155 WPtouch < 4.3.45 - Admin+ PHP Object Injection CVSS 3.1HIGH 8.8
- TI-2011-04131 SQL injection vulnerability in wptouch/ajax.php in the WPTouch plugin for WordPress… CVSS 2.0HIGH 7.5
- TI-2010-04502 Cross-site scripting (XSS) vulnerability in lib/includes/auth.inc.php in the WPtouch… CVSS 2.0MEDIUM 4.3
Sources
- CVE-2022-3416 · CVE Program
- CVE-2022-3416 · NVD
- FIRST EPSS
- GHSA-m7v9-fq6q-w2wp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences