WPtouch < 4.3.45 - Admin+ PHP Object Injection
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The WPtouch WordPress plugin before 4.3.45 unserialises the content of an imported settings file, which could lead to PHP object injections issues when an user import (intentionally or not) a malicious settings file and a suitable gadget chain is present on the blog.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WPtouch | before 4.3.45 | 4.3.45 | Patch available | CNA |
- WPtouch VendorUnknown Affected before 4.3.45 Fixed in 4.3.45 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:bravenewcode:wptouch:*:*:*:*:*:wordpress:*:* | before 4.3.45 | Vulnerable | Bravenewcode |
- cpe:2.3:a:bravenewcode:wptouch:*:*:*:*:*:wordpress:*:* Versions before 4.3.45 Vulnerable ·Bravenewcode
Remediation
- Fix · CNA WPtouch (Unknown) Fixed in 4.3.45
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
WPtouch 4.3.45
2 records Highest priority Priority HIGH 1 HIGH, 1 MEDIUM
Other records, highest priority first
- TI-2022-03154 WPtouch < 4.3.45 - Admin+ Arbitrary File UploadPriority HIGH 67
Timeline
- 2026-10-02 Threatist record created from CVE-2022-3417
- 2026-10-03 Alias added: GHSA-6rpp-h47m-wx9v
References
More Bravenewcode Wptouch vulnerabilities
- TI-2022-03154 WPtouch < 4.3.45 - Admin+ Arbitrary File Upload CVSS 3.1HIGH 7.2
- TI-2011-04131 SQL injection vulnerability in wptouch/ajax.php in the WPTouch plugin for WordPress… CVSS 2.0HIGH 7.5
- TI-2010-04502 Cross-site scripting (XSS) vulnerability in lib/includes/auth.inc.php in the WPtouch… CVSS 2.0MEDIUM 4.3
Sources
- CVE-2022-3417 · CVE Program
- CVE-2022-3417 · NVD
- FIRST EPSS
- GHSA-6rpp-h47m-wx9v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences