WP Attachments < 5.0.5 - Admin+ Stored Cross-Site Scripting
Priority MEDIUM 55CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The WP Attachments WordPress plugin before 5.0.5 does not sanitize and escapes some of its settings, which could allow high-privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example, in multisite setup).
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00583 48th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed WP Attachments (Unknown): 5.0.5
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WP Attachments | 5.0.5 to before 5.0.5 | 5.0.5 | Patch available | CNA |
- WP Attachments VendorUnknown Affected 5.0.5 to before 5.0.5 Fixed in 5.0.5 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:marcomilesi:wp_attachments:*:*:*:*:*:wordpress:*:* | before 5.0.5 | Vulnerable | Marco Milesi |
- cpe:2.3:a:marcomilesi:wp_attachments:*:*:*:*:*:wordpress:*:* Versions before 5.0.5 Vulnerable ·Marco Milesi
Remediation
- Fix · CNA WP Attachments (Unknown) Fixed in 5.0.5
Timeline
- 2026-10-02 Threatist record created from CVE-2022-3469
- 2026-10-03 Alias added: GHSA-r5c5-p2gw-prwf
References
More Marco Milesi Wp Attachments vulnerabilities
- TI-2023-24452 WordPress WP Attachments Plugin <= 5.0.11 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2022-03965 WP Attachments < 5.0.6 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
Sources
- CVE-2022-3469 · CVE Program
- CVE-2022-3469 · NVD
- FIRST EPSS
- GHSA-r5c5-p2gw-prwf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences