Read the docs
TI-2022-03965 Aliases CVE-2022-4330GHSA-7cjc-c9jv-7878

WP Attachments < 5.0.6 - Admin+ Stored XSS

Priority LOW 23CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The WP Attachments WordPress plugin before 5.0.6 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).

Why it matters now

EPSS 0.00475 41st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed WP Attachments (Unknown): 5.0.6

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownWP Attachmentsbefore 5.0.65.0.6Patch availableCNA
  • WP Attachments VendorUnknown Affected before 5.0.6 Fixed in 5.0.6 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:marcomilesi:wp_attachments:*:*:*:*:*:wordpress:*:*before 5.0.6VulnerableMarco Milesi
  • cpe:2.3:a:marcomilesi:wp_attachments:*:*:*:*:*:wordpress:*:* Versions before 5.0.6 Vulnerable ·Marco Milesi

Remediation

  • Fix · CNA WP Attachments (Unknown) Fixed in 5.0.6

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-4330
  2. 2026-10-03 Alias added: GHSA-7cjc-c9jv-7878

References

  • TI-2022-03203 WP Attachments < 5.0.5 - Admin+ Stored Cross-Site Scripting CVSS 3.1MEDIUM 4.8
  • TI-2023-24452 WordPress WP Attachments Plugin <= 5.0.11 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8

Sources