Read the docs
TI-2022-03315 Aliases CVE-2022-3602GHSA-8rwr-x37p-mx23

X.509 Email Address 4-byte Buffer Overflow

Priority HIGH 82CWE-787Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-787 and the CVSS impact.

Summary

A buffer overrun can be triggered in X.509 certificate verification, specifically in name constraint checking. Note that this occurs after certificate chain signature verification and requires either a CA to have signed the malicious certificate or for the application to continue certificate verification despite failure to construct a path to a trusted issuer. An attacker can craft a malicious email address to overflow four attacker-controlled bytes on the stack. This buffer overflow could result in a crash (causing a denial of service) or potentially remote code execution. Many platforms implement stack overflow protections which would mitigate against the risk of remote code execution. The risk may be further mitigated based on stack layout for any given platform/compiler. Pre-announcements of CVE-2022-3602 described this issue as CRITICAL. Further analysis based on some of the mitigating factors described above have led this to be downgraded to HIGH. Users are still encouraged to upgrade to a new version as soon as possible. In a TLS client, this can be triggered by connecting to a malicious server. In a TLS server, this can be triggered if the server requests client authentication and a malicious client connects. Fixed in OpenSSL 3.0.7 (Affected 3.0.0,3.0.1,3.0.2,3.0.3,3.0.4,3.0.5,3.0.6).

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.9077 99th percentileScored 2026-11-07
Fix Fixed openssl-src (crates.io): 300.0.11Red Hat: 2 advisories

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
OpenSSLOpenSSLFixed in OpenSSL 3.0.7 (Affected 3.0.0,3.0.1,3.0.2,3.0.3,3.0.4,3.0.5,3.0.6)—No fix listedCNA
—openssl-src (crates.io)300.0.0 to before 300.0.11300.0.11Patch availableGHSA-8rwr-x37p-mx23
  • OpenSSL VendorOpenSSL Affected Fixed in OpenSSL 3.0.7 (Affected 3.0.0,3.0.1,3.0.2,3.0.3,3.0.4,3.0.5,3.0.6) Fixed in — No fix listed CNA
  • openssl-src (crates.io) Vendor— Affected 300.0.0 to before 300.0.11 Fixed in 300.0.11 Patch available GHSA-8rwr-x37p-mx23

CPE configurations NVD · 9

CPEVersionsRoleVendor
cpe:2.3:a:openssl:openssl:*:*:*:*:*:*:*:*3.0.0 to before 3.0.7VulnerableOpenSSL
cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:*36VulnerableFedoraproject
cpe:2.3:o:fedoraproject:fedora:37:*:*:*:*:*:*:*37VulnerableFedoraproject
cpe:2.3:a:netapp:clustered_data_ontap:-:*:*:*:*:*:*:*not specified by NVDVulnerableNetApp
cpe:2.3:o:fedoraproject:fedora:26:*:*:*:*:*:*:*26VulnerableFedoraproject
cpe:2.3:o:fedoraproject:fedora:27:*:*:*:*:*:*:*27VulnerableFedoraproject
cpe:2.3:a:nodejs:node.js:*:*:*:*:-:*:*:*18.0.0 to before 18.11.0VulnerableNodeJS
cpe:2.3:a:nodejs:node.js:18.12.0:*:*:*:lts:*:*:*18.12.0VulnerableNodeJS
cpe:2.3:a:nodejs:node.js:19.0.0:*:*:*:-:*:*:*19.0.0VulnerableNodeJS
  • cpe:2.3:a:openssl:openssl:*:*:*:*:*:*:*:* Versions 3.0.0 to before 3.0.7 Vulnerable ·OpenSSL
  • cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:* Versions 36 Vulnerable ·Fedoraproject
  • cpe:2.3:o:fedoraproject:fedora:37:*:*:*:*:*:*:* Versions 37 Vulnerable ·Fedoraproject
  • cpe:2.3:a:netapp:clustered_data_ontap:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·NetApp
  • cpe:2.3:o:fedoraproject:fedora:26:*:*:*:*:*:*:* Versions 26 Vulnerable ·Fedoraproject
  • cpe:2.3:o:fedoraproject:fedora:27:*:*:*:*:*:*:* Versions 27 Vulnerable ·Fedoraproject
  • cpe:2.3:a:nodejs:node.js:*:*:*:*:-:*:*:* Versions 18.0.0 to before 18.11.0 Vulnerable ·NodeJS
  • cpe:2.3:a:nodejs:node.js:18.12.0:*:*:*:lts:*:*:* Versions 18.12.0 Vulnerable ·NodeJS
  • cpe:2.3:a:nodejs:node.js:19.0.0:*:*:*:-:*:*:* Versions 19.0.0 Vulnerable ·NodeJS

Remediation

  • Fix · GHSA-8rwr-x37p-mx23 openssl-src (crates.io) Fixed in 300.0.11 Advisory →

Red Hat 2 advisories

  • RHSA-2022:7384 Released 2022-11-02 · Red Hat rating Important
    openssl-container security update
    • Red Hat Enterprise Linux AppStream (v. 9) rhel9/openssl, ubi9/openssl
  • RHSA-2022:7288 Released 2022-11-01 · Red Hat rating Important
    openssl security update
    • Red Hat Enterprise Linux AppStream (v. 9) openssl-devel-1:3.0.1-43.el9_0, openssl-perl-1:3.0.1-43.el9_0
    • Red Hat Enterprise Linux BaseOS (v. 9) openssl-1:3.0.1-43.el9_0, openssl-libs-1:3.0.1-43.el9_0

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux AppStream (v. 9)Fixed RHSA-2022:7288, RHSA-2022:7384
Red Hat Enterprise Linux BaseOS (v. 9)Fixed RHSA-2022:7288
Not affected: 10 products
  • Red Hat Advanced Cluster Management for Kubernetes 2
  • Red Hat Enterprise Linux 6
  • Red Hat Enterprise Linux 7
  • Red Hat Enterprise Linux 8
  • Red Hat Enterprise Linux 9
  • Red Hat JBoss Core Services
  • Red Hat JBoss Enterprise Application Platform 6
  • Red Hat JBoss Web Server 3
  • Red Hat JBoss Web Server 5
  • Red Hat Virtualization 4

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-3602
  2. 2026-10-03 Alias added: GHSA-8rwr-x37p-mx23

References

Advisory 41

  • TI-2022-01915 The c_rehash script allows command injection CVSS 3.1CRITICAL 9.8
  • TI-2021-02645 SM2 Decryption Buffer Overflow CVSS 3.1CRITICAL 9.8
  • TI-2009-03392 The TLS protocol, and the SSL protocol 3.0 and possibly earlier, as used in Microsoft… CVSS 3.1CRITICAL 9.8
  • TI-2022-01176 The c_rehash script allows command injection CVSS 3.1CRITICAL 9.8
  • TI-2014-00154 The (1) TLS and (2) DTLS implementations in OpenSSL 1.0.1 before 1.0.1g do not properly… KEVCVSS 3.1HIGH 7.5
  • TI-2025-14107 Stack buffer overflow in CMS (Auth)EnvelopedData parsing CVSS 3.1HIGH 8.8
See all 312 →

Sources