WPQA < 5.9 - Follow/Unfollow via CSRF
Priority HIGH 73Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The WPQA Builder WordPress plugin before 5.9 does not have CSRF check when following and unfollowing users, which could allow attackers to make logged in users perform such actions via CSRF attacks
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00521 44th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed WPQA Builder (Unknown): 5.9
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WPQA Builder | before 5.9 | 5.9 | Patch available | CNA |
- WPQA Builder VendorUnknown Affected before 5.9 Fixed in 5.9 Patch available CNA
Remediation
- Fix · CNA WPQA Builder (Unknown) Fixed in 5.9
Timeline
- 2026-10-02 Threatist record created from CVE-2022-3688
- 2026-10-03 Alias added: GHSA-q58r-qh3r-4w5f
References
More 2code Wpqa Builder vulnerabilities
- TI-2024-02207 WPQA < 6.1.1 - Arbitrary Category and Tag Follow/Unfollow via CSRF CVSS 3.1HIGH 8.8
- TI-2024-02206 WPQA < 6.1.1 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.9
- TI-2022-03090 WPQA < 5.9.3 - Missing validation lead to functionality abuse CVSS 3.1LOW 3.5
- TI-2022-01467 WPQA < 5.4 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2022-01468 WPQA < 5.5 - Unauthenticated Private Message Disclosure CVSS 3.1MEDIUM 5.3
- TI-2022-00948 WPQA < 5.2 - Subscriber+ Stored Cross-Site Scripting via Profile fields CVSS 3.1MEDIUM 5.4
Sources
- CVE-2022-3688 · CVE Program
- CVE-2022-3688 · NVD
- FIRST EPSS
- GHSA-q58r-qh3r-4w5f · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences