Read the docs

2code

Records21All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical0CVSS 9.0–10.0
CVSS high3CVSS 7.0–8.9

Exploited now

2code records in CISA KEV

No 2code vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

21 records

Priority HIGH 73

The WPQA Builder WordPress plugin before 6.1.1 does not have CSRF checks in some places, which could allow attackers to make logged in users perform unwanted actions via CSRF attacks

CVSS 3.1HIGH 8.8 Network No auth User interaction EPSS 0.00418 Published 2024-07-03 Fixed in 6.1.1 CWE-352
TI-2022-03390 CVE-2022-3688 · GHSA-q58r-qh3r-4w5f

WPQA < 5.9 - Follow/Unfollow via CSRF

Priority HIGH 73

The WPQA Builder WordPress plugin before 5.9 does not have CSRF check when following and unfollowing users, which could allow attackers to make logged in users perform such actions via CSRF attacks

CVSS 3.1HIGH 8.8 Network No auth User interaction EPSS 0.00521 Published 2022-11-21 Fixed in 5.9
Priority MEDIUM 61

The Himer WordPress theme before 2.1.1 does not sanitise and escape some of its Post settings, which could allow high privilege users such as Contributor to perform Stored Cross-Site Scripting attacks

CVSS 3.1MEDIUM 6.3 Network No auth User interaction EPSS 0.00335 Published 2024-07-03 Fixed in 2.1.1 CWE-79
TI-2024-02206 CVE-2024-2375 · GHSA-2gf8-64pg-49p7

WPQA < 6.1.1 - Contributor+ Stored XSS

Priority MEDIUM 60

The WPQA Builder WordPress plugin before 6.1.1 does not sanitise and escape some of its Slider settings, which could allow high privilege users such as contributor to perform Stored Cross-Site Scripting attacks

CVSS 3.1MEDIUM 5.9 Network High privileges User interaction EPSS 0.00329 Published 2024-07-03 Fixed in 6.1.1 CWE-79
Priority MEDIUM 50

The WPQA Builder WordPress plugin before 5.9.3 (which is a companion plugin used with Discy and Himer Discy WordPress themes) incorrectly tries to validate that a user already follows another in the wpqa_following_you_aj…

CVSS 3.1LOW 3.5 Network Low privileges User interaction EPSS 0.00493 Published 2023-01-09 Fixed in 5.9.3, 5.5.3 +1
Priority LOW 33

The WPQA Builder WordPress plugin before 5.4, used as a companion for the Discy and Himer , does not sanitise and escape a parameter on its reset password form which makes it possible to perform Reflected Cross-Site Scri…

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.03042 Published 2022-06-06 Fixed in 5.4 CWE-79
Priority LOW 32

The WPQA Builder WordPress plugin before 5.5 which is a companion to the Discy and Himer , lacks authentication in a REST API endpoint, allowing unauthenticated users to discover private questions sent between users on t…

CVSS 3.1MEDIUM 5.3 Network No auth No interaction EPSS 0.05383 Published 2022-06-06 Fixed in 5.5 CWE-306
Priority LOW 30

The Ask me WordPress theme before 6.8.2 does not perform CSRF checks for any of its AJAX actions, allowing an attacker to trick logged in users to perform various actions on their behalf on the site.

CVSS 3.1MEDIUM 6.5 Network No auth User interaction EPSS 0.00542 Published 2022-06-06 Fixed in 6.8.2 CWE-352
Priority LOW 30

The Discy WordPress theme before 5.2 does not check for CSRF tokens in the AJAX action discy_reset_options, allowing an attacker to trick an admin into resetting the site settings back to defaults.

CVSS 3.1MEDIUM 6.5 Network No auth User interaction EPSS 0.00542 Published 2022-06-06 Fixed in 5.2 CWE-352
Priority LOW 30

The Discy WordPress theme before 5.0 lacks authorization checks then processing ajax requests to the discy_update_options action, allowing any logged in users (with privileges as low as Subscriber,) to change Theme optio…

CVSS 3.1MEDIUM 6.5 Network Low privileges No interaction EPSS 0.00769 Published 2022-08-08 Fixed in 5.0 CWE-862
Priority LOW 29

The Ask me WordPress theme before 6.8.2 does not properly sanitise and escape several of the fields in the Edit Profile page, leading to Reflected Cross-Site Scripting issues

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.008 Published 2022-06-06 Fixed in 6.8.2 CWE-79
Priority LOW 27

The WPQA Builder Plugin WordPress plugin before 5.2, used as a companion plugin for the Discy and Himer , does not sanitise and escape the city, phone or profile credentials fields when outputting it in the profile page,…

CVSS 3.1MEDIUM 5.4 Network Low privileges User interaction EPSS 0.01291 Published 2022-05-16 Fixed in 5.2 CWE-79
TI-2022-01302 CVE-2022-1421 · GHSA-mpq8-cm6q-wpq8

Discy < 5.2 - Settings Update via CSRF

Priority LOW 23

The Discy WordPress theme before 5.2 lacks CSRF checks in some AJAX actions, allowing an attacker to make a logged in admin change arbitrary 's settings including payment methods via a CSRF attack

CVSS 3.1MEDIUM 4.3 Network No auth User interaction EPSS 0.01316 Published 2022-06-06 Fixed in 5.2 CWE-352
Priority LOW 21

The WPQA Builder WordPress plugin before 5.7 which is a companion plugin to the Hilmer and Discy , does not check authorization before displaying private messages, allowing any logged in user to read other users private…

CVSS 3.1MEDIUM 4.3 Network Low privileges No interaction EPSS 0.00753 Published 2022-08-22 Fixed in 5.7 CWE-639
Priority LOW 21

The WPQA Builder Plugin WordPress plugin before 5.2, used as a companion plugin for the Discy and Himer , does not validate that the message_id of the wpqa_message_view ajax action belongs to the requesting user, leading…

CVSS 3.1MEDIUM 4.3 Network Low privileges No interaction EPSS 0.00799 Published 2022-05-16 Fixed in 5.2 CWE-639
Priority LOW 21

The WPQA Builder Plugin WordPress plugin before 5.2, used as a companion plugin for the Discy and Himer , does not validate that the value passed to the image_id parameter of the ajax action wpqa_remove_image belongs to…

CVSS 3.1MEDIUM 4.3 Network Low privileges No interaction EPSS 0.00654 Published 2022-05-16 Fixed in 5.2 CWE-287
Open these records in search →