Read the docs
TI-2022-03393 Aliases CVE-2022-3691GHSA-29rj-95hw-fhm9

DeepL Pro API Translation < 1.7.5 - API Key Disclosure

Priority HIGH 66CWE-552Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-552.

Summary

The DeepL Pro API translation plugin WordPress plugin before 1.7.5 discloses sensitive information (including the DeepL API key) in files that are publicly accessible to an external, unauthenticated visitor.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0096 61st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed DeepL Pro API translation plugin (Unknown): 1.7.5

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownDeepL Pro API translation pluginbefore 1.7.51.7.5Patch availableCNA
  • DeepL Pro API translation plugin VendorUnknown Affected before 1.7.5 Fixed in 1.7.5 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:fluenx:deepl_pro_api_translation:*:*:*:*:*:wordpress:*:*before 1.7.5VulnerableFluenx
  • cpe:2.3:a:fluenx:deepl_pro_api_translation:*:*:*:*:*:wordpress:*:* Versions before 1.7.5 Vulnerable ·Fluenx

Remediation

  • Fix · CNA DeepL Pro API translation plugin (Unknown) Fixed in 1.7.5

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-3691
  2. 2026-10-03 Alias added: GHSA-29rj-95hw-fhm9

References

  • TI-2023-12178 WordPress DeepL Pro API translation Plugin <= 2.1.4 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8

Sources