Read the docs
TI-2022-03524 Aliases CVE-2022-3844GHSA-rm6j-m6w6-q2q3

Webmin index.cgi cross site scripting

Priority LOW 29CWE-80Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
No fix listed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-80.

Summary

A vulnerability, which was classified as problematic, was found in Webmin 2.001. Affected is an unknown function of the file xterm/index.cgi. The manipulation leads to basic cross site scripting. It is possible to launch the attack remotely. Upgrading to version 2.003 is able to address this issue. The patch is identified as d3d33af3c0c3fd3a889c84e287a038b7a457d811. It is recommended to upgrade the affected component. VDB-212862 is the identifier assigned to this vulnerability.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00841 58th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—Webmin2.001—No fix listedCNA
  • Webmin Vendor— Affected 2.001 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:webmin:webmin:2.001:*:*:*:*:*:*:*2.001VulnerableWebmin
  • cpe:2.3:a:webmin:webmin:2.001:*:*:*:*:*:*:* Versions 2.001 Vulnerable ·Webmin

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-3844
  2. 2026-10-03 Alias added: GHSA-rm6j-m6w6-q2q3
  3. 2026-10-08 EPSS moved to the 50th–90th percentile

References

  • TI-2019-11278 An issue was discovered in Webmin <=1.920. KEVCVSS 3.1CRITICAL 9.8
  • TI-2022-16770 software/apt-lib.pl in Webmin before 1.997 lacks HTML escaping for a UI command. CVSS 3.1CRITICAL 9.8
  • TI-2022-00731 Improper Access Control to Remote Code Execution in webmin/webmin CVSS 3.1HIGH 8.8
  • TI-2019-09619 In Webmin through 1.910, any user authorized to the "Package Updates" module can execute… CVSS 3.0HIGH 8.8
  • TI-2021-11777 Webmin 1.973 is affected by reflected Cross Site Scripting (XSS) to achieve Remote… CVSS 3.1CRITICAL 9.6
  • TI-2024-11888 OS command injection in Webmin CVSS 3.1HIGH 8.8
See all 95 →

Sources