Chaty < 3.0.3 - Admin+ SQLi
Priority HIGH 67Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Floating Chat Widget: Contact Chat Icons, Telegram Chat, Line, WeChat, Email, SMS, Call Button WordPress plugin before 3.0.3 does not properly sanitise and escape a parameter before using it in a SQL statement, leading to a SQL injection exploitable by users with a role as low as admin.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01062 64th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Floating Chat Widget: Contact Chat Icons, Telegram Chat, Line, WeChat, Email, SMS, Call Button (Unknown): 3.0.3
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Floating Chat Widget: Contact Chat Icons, Telegram Chat, Line, WeChat, Email, SMS, Call Button | before 3.0.3 | 3.0.3 | Patch available | CNA |
- Floating Chat Widget: Contact Chat Icons, Telegram Chat, Line, WeChat, Email, SMS, Call Button VendorUnknown Affected before 3.0.3 Fixed in 3.0.3 Patch available CNA
Remediation
- Fix · CNA Floating Chat Widget: Contact Chat Icons, Telegram Chat, Line, WeChat, Email, SMS, Call Button (Unknown) Fixed in 3.0.3
Timeline
- 2026-10-02 Threatist record created from CVE-2022-3858
- 2026-10-03 Alias added: GHSA-gx37-5pp8-f39c
References
More premio Chaty vulnerabilities
- TI-2023-03041 Floating Chat Widget < 3.1.2 - Admin+ Stored Cross-Site Scripting CVSS 3.1MEDIUM 4.8
- TI-2023-10492 WordPress Chaty Plugin <= 3.0.9 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
- TI-2021-07294 Chaty < 2.8.3 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2023-25869 WordPress Chaty plugin <= 3.1.2 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 5.9
- TI-2021-14944 WordPress Chaty plugin <= 2.8.3 - Authenticated Stored Cross-Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 4.8
Sources
- CVE-2022-3858 · CVE Program
- CVE-2022-3858 · NVD
- FIRST EPSS
- GHSA-gx37-5pp8-f39c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences