Floating Chat Widget < 3.1.2 - Admin+ Stored Cross-Site Scripting
Priority MEDIUM 55CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Floating Chat Widget WordPress plugin before 3.1.2 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00455 39th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Floating Chat Widget: Contact Chat Icons, Telegram Chat, Line Messenger, WeChat, Email, SMS, Call Button (Unknown): 3.1.2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Floating Chat Widget: Contact Chat Icons, Telegram Chat, Line Messenger, WeChat, Email, SMS, Call Button | before 3.1.2 | 3.1.2 | Patch available | CNA |
- Floating Chat Widget: Contact Chat Icons, Telegram Chat, Line Messenger, WeChat, Email, SMS, Call Button VendorUnknown Affected before 3.1.2 Fixed in 3.1.2 Patch available CNA
Remediation
- Fix · CNA Floating Chat Widget: Contact Chat Icons, Telegram Chat, Line Messenger, WeChat, Email, SMS, Call Button (Unknown) Fixed in 3.1.2
Timeline
- 2026-10-02 Threatist record created from CVE-2023-3245
- 2026-10-03 Alias added: GHSA-vrpj-wv5c-r9r4
References
More premio Chaty vulnerabilities
- TI-2022-03536 Chaty < 3.0.3 - Admin+ SQLi CVSS 3.1HIGH 7.2
- TI-2023-10492 WordPress Chaty Plugin <= 3.0.9 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
- TI-2021-07294 Chaty < 2.8.3 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2023-25869 WordPress Chaty plugin <= 3.1.2 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 5.9
- TI-2021-14944 WordPress Chaty plugin <= 2.8.3 - Authenticated Stored Cross-Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 4.8
Sources
- CVE-2023-3245 · CVE Program
- CVE-2023-3245 · NVD
- FIRST EPSS
- GHSA-vrpj-wv5c-r9r4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences