Read the docs
TI-2022-03569 Aliases CVE-2022-3892GHSA-mqjq-qch6-x888

WP OAuth Server < 4.2.2 - Admin+ Stored XSS

Priority MEDIUM 55Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.

Summary

The WP OAuth Server (OAuth Authentication) WordPress plugin before 4.2.2 does not sanitize and escape Client IDs, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0051 43rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed WP OAuth Server (OAuth Authentication) (Unknown): 4.2.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownWP OAuth Server (OAuth Authentication)before 4.2.24.2.2Patch availableCNA
  • WP OAuth Server (OAuth Authentication) VendorUnknown Affected before 4.2.2 Fixed in 4.2.2 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:wp-oauth:wp_oauth_server:*:*:*:*:*:wordpress:*:*before 4.2.2VulnerableWp-oauth
  • cpe:2.3:a:wp-oauth:wp_oauth_server:*:*:*:*:*:wordpress:*:* Versions before 4.2.2 Vulnerable ·Wp-oauth

Remediation

  • Fix · CNA WP OAuth Server (OAuth Authentication) (Unknown) Fixed in 4.2.2

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-3892
  2. 2026-10-03 Alias added: GHSA-mqjq-qch6-x888

References

  • TI-2022-03601 WP OAuth Server < 3.4.2 - Client Secret Regeneration via CSRF CVSS 3.1MEDIUM 6.5
  • TI-2024-20629 WordPress WP OAuth Server (OAuth Authentication) plugin <= 4.3.3 - Open Redirection vulnerability CVSS 3.1MEDIUM 6.1

Sources