MonsterInsights < 8.9.1 - Stored Cross-Site Scripting via Google Analytics
Priority HIGH 68CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The MonsterInsights WordPress plugin before 8.9.1 does not sanitize or escape page titles in the top posts/pages section, allowing an unauthenticated attacker to inject arbitrary web scripts into the titles by spoofing requests to google analytics.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01353 71st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed MonsterInsights (Unknown): 8.9.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | MonsterInsights | before 8.9.1 | 8.9.1 | Patch available | CNA |
- MonsterInsights VendorUnknown Affected before 8.9.1 Fixed in 8.9.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:monsterinsights:monsterinsights:*:*:*:*:*:wordpress:*:* | before 8.9.1 | Vulnerable | MonsterInsights |
- cpe:2.3:a:monsterinsights:monsterinsights:*:*:*:*:*:wordpress:*:* Versions before 8.9.1 Vulnerable ·MonsterInsights
Remediation
- Fix · CNA MonsterInsights (Unknown) Fixed in 8.9.1
Timeline
- 2026-10-02 Threatist record created from CVE-2022-3904
- 2026-10-03 Alias added: GHSA-cjcj-g2w6-gp9q
References
More Monsterinsights vulnerabilities
- TI-2023-00077 MonsterInsights < 8.12.1 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2023-15587 WordPress MonsterInsights Pro Plugin <= 8.14.1 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
Sources
- CVE-2022-3904 · CVE Program
- CVE-2022-3904 · NVD
- FIRST EPSS
- GHSA-cjcj-g2w6-gp9q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences