MonsterInsights < 8.12.1 - Contributor+ Stored XSS
Priority MEDIUM 58Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The MonsterInsights WordPress plugin before 8.12.1 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00589 48th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed MonsterInsights (Unknown): 8.12.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | MonsterInsights | before 8.12.1 | 8.12.1 | Patch available | CNA |
- MonsterInsights VendorUnknown Affected before 8.12.1 Fixed in 8.12.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:monsterinsights:monsterinsights:*:*:*:*:*:wordpress:*:* | before 8.12.1 | Vulnerable | MonsterInsights |
- cpe:2.3:a:monsterinsights:monsterinsights:*:*:*:*:*:wordpress:*:* Versions before 8.12.1 Vulnerable ·MonsterInsights
Remediation
- Fix · CNA MonsterInsights (Unknown) Fixed in 8.12.1
Timeline
- 2026-10-02 Threatist record created from CVE-2023-0081
- 2026-10-03 Alias added: GHSA-7w85-qxmf-mpxc
References
More Monsterinsights vulnerabilities
- TI-2022-03581 MonsterInsights < 8.9.1 - Stored Cross-Site Scripting via Google Analytics CVSS 3.1MEDIUM 6.1
- TI-2023-15587 WordPress MonsterInsights Pro Plugin <= 8.14.1 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
Sources
- CVE-2023-0081 · CVE Program
- CVE-2023-0081 · NVD
- FIRST EPSS
- GHSA-7w85-qxmf-mpxc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences