Ultimate Member Plugin Template class-shortcodes.php load_template pathname traversal
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-22 and the CVSS impact.
Summary
A vulnerability, which was classified as critical, has been found in Ultimate Member Plugin up to 2.5.0. This issue affects the function load_template of the file includes/core/class-shortcodes.php of the component Template Handler. The manipulation of the argument tpl leads to pathname traversal. The attack may be initiated remotely. Upgrading to version 2.5.1 is able to address this issue. The name of the patch is e1bc94c1100f02a129721ba4be5fbc44c3d78ec4. It is recommended to upgrade the affected component. The identifier VDB-213545 was assigned to this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| unspecified | Ultimate Member Plugin | 2.0; 2.1; 2.2; 2.3; 2.4; 2.5 | — | No fix listed | CNA |
- Ultimate Member Plugin Vendorunspecified Affected 2.0; 2.1; 2.2; 2.3; 2.4; 2.5 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ultimatemember:ultimate_member:*:*:*:*:*:wordpress:*:* | before 2.5.1 | Vulnerable | ultimatemember |
- cpe:2.3:a:ultimatemember:ultimate_member:*:*:*:*:*:wordpress:*:* Versions before 2.5.1 Vulnerable ·ultimatemember
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2022-3966
- 2026-10-03 Alias added: GHSA-h2hj-3x68-wc2c
References
More ultimatemember Ultimate Member vulnerabilities
- TI-2024-00992 SQL injection in ultimatemember Ultimate Member – User Profile, Registration, Login… CVSS 3.1CRITICAL 9.8
- TI-2023-03232 Ultimate Member < 2.6.7 - Unauthenticated Privilege Escalation CVSS 3.1CRITICAL 9.8
- TI-2024-01973 Ultimate Member <= 2.8.3 - Unauthenticated Stored Cross-Site Scripting CVSS 3.1HIGH 7.2
- TI-2020-18475 An issue was discovered in the Ultimate Member plugin before 2.1.12 for WordPress, aka… CVSS 3.1CRITICAL 10.0
- TI-2020-18477 An issue was discovered in the Ultimate Member plugin before 2.1.12 for WordPress, aka… CVSS 3.1CRITICAL 10.0
- TI-2020-18476 An issue was discovered in the Ultimate Member plugin before 2.1.12 for WordPress, aka… CVSS 3.1CRITICAL 9.9
Sources
- CVE-2022-3966 · CVE Program
- CVE-2022-3966 · NVD
- FIRST EPSS
- GHSA-h2hj-3x68-wc2c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences