Booking Calendar < 3.2.2 - Unauthenticated Arbitrary File Upload
Priority HIGH 82Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Booking calendar, Appointment Booking System WordPress plugin before 3.2.2 does not validate uploaded files, which could allow unauthenticated users to upload arbitrary files, such as PHP and achieve RCE
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.04809 92nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Booking calendar, Appointment Booking System (Unknown): 3.2.2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Booking calendar, Appointment Booking System | before 3.2.2 | 3.2.2 | Patch available | CNA |
- Booking calendar, Appointment Booking System VendorUnknown Affected before 3.2.2 Fixed in 3.2.2 Patch available CNA
Remediation
- Fix · CNA Booking calendar, Appointment Booking System (Unknown) Fixed in 3.2.2
Timeline
- 2026-10-02 Threatist record created from CVE-2022-3982
- 2026-10-03 Alias added: GHSA-7v4v-c3pr-fgrq
References
More wpdevart Booking Calendar vulnerabilities
- TI-2022-23505 WordPress Booking calendar, Appointment Booking System Plugin <= 3.2.7 is vulnerable to SQL Injection CVSS 3.1CRITICAL 9.8
- TI-2023-09995 WordPress Booking calendar, Appointment Booking System plugin <= 3.2.3 - Bypass vulnerability CVSS 3.1CRITICAL 9.8
- TI-2023-10029 WordPress Booking calendar, Appointment Booking System plugin <= 3.2.3 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
- TI-2018-07335 An issue was discovered in the WpDevArt "Booking calendar, Appointment Booking System"… CVSS 3.0HIGH 7.5
- TI-2024-10064 Booking Calendar WpDevArt <= 3.2.19 - Authenticated (Contributor+) SQL Injection CVSS 3.1MEDIUM 6.5
- TI-2022-23515 WordPress Booking calendar, Appointment Booking System Plugin <= 3.2.3 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9
Sources
- CVE-2022-3982 · CVE Program
- CVE-2022-3982 · NVD
- FIRST EPSS
- GHSA-7v4v-c3pr-fgrq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences