Booster for WooCommerce - Custom Role Creation/Deletion via CSRF
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Booster for WooCommerce WordPress plugin before 5.6.7, Booster Plus for WooCommerce WordPress plugin before 5.6.6, Booster Elite for WooCommerce WordPress plugin before 1.1.8 does not properly check for CSRF when creating and deleting Customer roles, allowing attackers to make logged admins create and delete arbitrary custom roles via CSRF attacks
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Booster for WooCommerce | before 5.6.7 | 5.6.7 | Patch available | CNA |
| Unknown | Booster Plus for WooCommerce | before 5.6.6 | 5.6.6 | Patch available | CNA |
| Unknown | Booster Elite for WooCommerce | before 1.1.8 | 1.1.8 | Patch available | CNA |
- Booster for WooCommerce VendorUnknown Affected before 5.6.7 Fixed in 5.6.7 Patch available CNA
- Booster Plus for WooCommerce VendorUnknown Affected before 5.6.6 Fixed in 5.6.6 Patch available CNA
- Booster Elite for WooCommerce VendorUnknown Affected before 1.1.8 Fixed in 1.1.8 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:booster:booster_for_woocommerce:*:*:*:*:elite:wordpress:*:* | before 1.1.8 | Vulnerable | pluggabl |
| cpe:2.3:a:booster:booster_for_woocommerce:*:*:*:*:plus:wordpress:*:* | before 5.6.6 | Vulnerable | pluggabl |
| cpe:2.3:a:booster:booster_for_woocommerce:*:*:*:*:*:wordpress:*:* | before 5.6.7 | Vulnerable | pluggabl |
- cpe:2.3:a:booster:booster_for_woocommerce:*:*:*:*:elite:wordpress:*:* Versions before 1.1.8 Vulnerable ·pluggabl
- cpe:2.3:a:booster:booster_for_woocommerce:*:*:*:*:plus:wordpress:*:* Versions before 5.6.6 Vulnerable ·pluggabl
- cpe:2.3:a:booster:booster_for_woocommerce:*:*:*:*:*:wordpress:*:* Versions before 5.6.7 Vulnerable ·pluggabl
Remediation
- Fix · CNA Booster for WooCommerce (Unknown) Fixed in 5.6.7
- Fix · CNA Booster Plus for WooCommerce (Unknown) Fixed in 5.6.6
- Fix · CNA Booster Elite for WooCommerce (Unknown) Fixed in 1.1.8
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4016
- 2026-10-03 Alias added: GHSA-fh57-58q7-6v93
References
More pluggabl Booster For Woocommerce vulnerabilities
- TI-2021-13660 Booster for WooCommerce <= 5.4.3 Authentication Bypass CVSS 3.1CRITICAL 9.8
- TI-2022-03454 Booster for WooCommerce - Checkout Files Deletion via CSRF CVSS 3.1HIGH 8.1
- TI-2022-03453 Booster for WooCommerce - ShopManager+ Arbitrary File Download CVSS 3.1MEDIUM 6.5
- TI-2024-12783 Booster for WooCommerce 4.0.1 - 7.2.4 - Unauthenticated Arbitrary File Upload CVSS 3.1CRITICAL 9.8
- TI-2024-12385 Booster for WooCommerce <= 7.2.4 - Unauthenticated Double Extension Arbitrary File Upload CVSS 3.1CRITICAL 9.8
- TI-2024-01848 Elite Booster for WooCommerce <= 7.1.7 - Authenticated (Subscriber+) Arbitrary File Upload CVSS 3.1HIGH 8.8
Sources
- CVE-2022-4016 · CVE Program
- CVE-2022-4016 · NVD
- FIRST EPSS
- GHSA-fh57-58q7-6v93 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences