Booster for WooCommerce - Multiple CSRF
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Booster for WooCommerce WordPress plugin before 6.0.1, Booster Plus for WooCommerce WordPress plugin before 6.0.1, Booster Elite for WooCommerce WordPress plugin before 6.0.1 have either flawed CSRF checks or are missing them completely in numerous places, allowing attackers to make logged in users perform unwanted actions via CSRF attacks
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Booster for WooCommerce | before 6.0.1 | 6.0.1 | Patch available | CNA |
| Unknown | Booster Plus for WooCommerce | before 6.0.1 | 6.0.1 | Patch available | CNA |
| Unknown | Booster Elite for WooCommerce | before 6.0.1 | 6.0.1 | Patch available | CNA |
- Booster for WooCommerce VendorUnknown Affected before 6.0.1 Fixed in 6.0.1 Patch available CNA
- Booster Plus for WooCommerce VendorUnknown Affected before 6.0.1 Fixed in 6.0.1 Patch available CNA
- Booster Elite for WooCommerce VendorUnknown Affected before 6.0.1 Fixed in 6.0.1 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:booster:booster_elite_woocommerce:*:*:*:*:*:wordpress:*:* | before 6.0.1 | Vulnerable | pluggabl |
| cpe:2.3:a:booster:booster_for_woocommerce:*:*:*:*:*:wordpress:*:* | before 6.0.1 | Vulnerable | pluggabl |
| cpe:2.3:a:booster:booster_plus_woocommerce:*:*:*:*:*:wordpress:*:* | before 6.0.1 | Vulnerable | pluggabl |
- cpe:2.3:a:booster:booster_elite_woocommerce:*:*:*:*:*:wordpress:*:* Versions before 6.0.1 Vulnerable ·pluggabl
- cpe:2.3:a:booster:booster_for_woocommerce:*:*:*:*:*:wordpress:*:* Versions before 6.0.1 Vulnerable ·pluggabl
- cpe:2.3:a:booster:booster_plus_woocommerce:*:*:*:*:*:wordpress:*:* Versions before 6.0.1 Vulnerable ·pluggabl
Remediation
- Fix · CNA Booster for WooCommerce (Unknown) Fixed in 6.0.1
- Fix · CNA Booster Plus for WooCommerce (Unknown) Fixed in 6.0.1
- Fix · CNA Booster Elite for WooCommerce (Unknown) Fixed in 6.0.1
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4017
- 2026-10-03 Alias added: GHSA-vq5p-mxwf-g858
References
Sources
- CVE-2022-4017 · CVE Program
- CVE-2022-4017 · NVD
- FIRST EPSS
- GHSA-vq5p-mxwf-g858 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences